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Chapter 1

Introduction

1.1 Purpose

This manual describes the Observing Tool (OT), that is used to define observing proposals and to prepare
observations at the Atacama Large Millimeter/submillimeter Array (ALMA).

If you intend to request observing time on ALMA (Phase 1), or if you have obtained observing time and
need to define the instrument details for the observing programme (Phase 2), you will need to use the OT. The
purpose of this manual is to assist you in the Phase 1 proposal creation and in the Phase 2 programme definition
and submission processes.

The OT is a Java based application integrating a set of user interfaces that are needed to prepare an ALMA
observing project. An ALMA ProjectALMA Project consists of a valid ALMA Observing Proposal and an
Observing Programme containing one or more Scheduling Blocks that are executed at the telescope. The OT
and the Scheduling Blocks are important constituents of the ALMA Data Flow System. This manual will also
describe these concepts.

This manual is not a technical manual. Hence, detailed technical information about the ALMA hardware
systems will not be presented in this manual. However, the manual covers some technical aspects of, and
references to, the ALMA hardware that enables users to set up more complicated observing programmes and
non-standard configurations. Also, the manual provides guidelines for the installation of the OT.

Chapter 2 provides information about how to install, configure and run the Observing Tool. More installation
and configuration details are provided in a separate Appendix A. Chapter 3 describes the basics concepts of the
Observing Tool and the main components of an observing proposal and observing programme. An overview of
the Observing Tool is given in Chapter 4. The ALMA Sensitivity Calculator and the Calibrator Selection Tool
are discussed in Chapter 5.

The creation of Phase 1 proposals is described in Chapter 6. Chapters 7 and 8 provide comprehensive infor-
mation about setting up a Phase 2 programme by defining Science Goals (Chapter 7) or by creating Scheduling
Blocks (Chapter 8). For creating a Phase 1 proposal or a Phase 2 programme the OT provides so-called Visual
Editors. The Visual Spatial Editor displays an area of the sky with field and pointing information. The Visual
Spectral Editor supports frequency and correlator settings in a graphical represeantion. The Visual Spatial and
Spectra Editors are documented in Chapters 9 and 10, respectively.

In Chapter 11 the validation of observing proposals and programmes is discussed, provides information on
how to submit and retrieve a project to and from the ALMA Observatory, and how to store and load projects
locally.

A number of Appendices cover special topics: Installation details and Configuration, Project Migration,
Information for Expert users and Troubleshooting.
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1.2 Release Information

This version of the manual is consistent with the OT Release for Cycle 0 of Early Science (March 2011).

The OT provides tools for both the creation of a Phase 1 Proposal, for defining of a Phase 2 Observing
Programme, and for submission to the ALMA Archive. Hence tools and services are provided in the OT to
support ALMA programmes end-to-end. Note, however, that development will continue in the forthcoming
releases and that these services will be improved and further developed.

Although you do not need to register with ALMA in order to download the OT, you will need to be regis-
tered to submit a proposal. Registration and OT download can be accomplished at the ALMA Science Portal:
http://www.almascience.org

1.3 Reference Manual and Quickstart Guide

This Observing Tool manual is intended for all ALMA users: “normal” users, novices, as well as very experienced
ones. It provides comprehensive information about how to create valid Phase 1 proposals and Phase 2 programmes
for observing astronomical objects. Special functions of the OT, e.g. for creating holography and optical pointing,
are not described in this manual. In addition, a Quickstart Guide is available that shows how to create an ALMA
Phase 1 proposal in 10 easy steps – this is available through the ALMA Science Portal.

The OT User Manual provides information about the various menus, required inputs and interfaces of the OT
in a certain degree of detail. However, giving full information about all fields and menus would make this User
Manual hard to read. Therefore, an ALMA OT Reference Manual is available which contains comprehensive
descriptions of all fields and parameters, together with illustrations of the OT where they occur.

1.4 User Support

In the three partner regions, an ALMA Regional Center (ARC) has been established. Each ARC can provide
user support in the core areas of proposal preparation (Phase 1), observation programme preparation (Phase 2)
and data analysis, to users in their respective communities. Therefore, staff at the ARCs will be able to help
with any problems you might be encountering with the OT.

The primary route for obtaining assistance is through the ALMA Helpdesk. This is available from the ALMA
Science Portal, which also contains links to the websites of the three ARCs. The Cycle O release of the ALMA
Observing Tool is the first official release of the OT for supporting the submission of Early Science ALMA
proposals. Being the first release, it may show limitations in particular areas. If you encounter a problem or
need support when using the ALMA Observing Tool, you should file a ticket at the ALMA Helpdesk. The url
of the ALMA Science Portal is:

http://www.almascience.org

1.5 Credits and Acknowledgments

The ALMA OT is a software product of the ALMA Observation Preparation Software Team and is developed
on the basis of the ALMA Science Software Requirements (SSR) and the ALMA High Level Analysis (HLA)
documents, produced by the respective groups. The OT software group acknowledges the valuable inputs of
these groups during the development phases of the OT. Also, the OT software groups thank the OT external
community testing group for their testing efforts of the various versions of the OT.
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Chapter 2

Install and Run the Observing Tool

To prepare a Phase 1 proposal, or to specify an observing programme during the Phase 2 process, you need
to have access to the OT application. Two methods are provided to install and run the OT on your machine.
The first and recommended method is to use the Java Web Start installation. Provided a network connection is
available, Web Start will ensure that you are running the latest available version of the OT. The second method
is a more classical installation by downloading and unpacking a tarfile containing the OT application and other
files required to run the OT.

In this chapter, both installation procedures will be discussed. Before dealing with these two installation
methods, topics that are independent of the installation method will be presented first. These include supported
platforms, disk space requirements and the availability of Java.

2.1 Hardware and Software Prerequisites

For novice users in particular, when starting to read Chapter 4 it is recommended to import a tutorial example
file to the OT. Section 11.1 describes how to import files into the OT. Alternatively, the Template Library in the
Project Structure pane of the OT (see Section 4.2.4) contains a number of examples using different instrumental
setups.

2.1.1 Supported Platforms

At present, ALMA officially supports the OT for Sun/Solaris, RedHat 7, 9, and RedHat Enterprise, Linux Fedora
and Scientific Linux and Suse Linux versions 7, 9 and 10, Windows 7, XP, VISTA and MAC OSX (Leopard and
Snow Leopard). Provided the correct Java software is installed (see below), the OT will run on these platforms.

Note that, except for the Web Start application (see Section 2.2), the OT does not have a facility to trace bugs.
Consequently, it can be difficult to reproduce and understand bugs if the description is incomplete. Therefore,
to work successfully on a problem the OT development team will need a detailed description of it, including the
steps that show how the problem can be reproduced. Also they need the version number of the Java software
you are using.

2.1.2 Disk Space Required

The Web Start installation requires 115 MB, the tarball distribution that contains the Java Runtime Environment
(see below) requires 142 MB and the tarball without the JRE requires 101 MB. If the Web Start is used to
install the OT, this space must be available in the location where Web Start is configured to install downloaded
applications. The default for this will be a subdirectory of your home space (Unix/MAC/Linux) or in the profile
area (Windows). In case of a tarball installation the disk space must be available in the location where the OT
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will be installed.

2.1.3 Java Software

The OT is a Java application that will work on any compatible Java Virtual Machine (JVM) installed on your
platform. The JVM, if correctly installed, executes the OT platform independent binary code. The JVM is
part of the so-called Java Runtime Environment (JRE), which is the software environment in which programmes
compiled for a JVM implementation can run (see Appendix B.1).

Because of its Java dependency, installing and running the ALMA OT requires the Java Runtime Environ-
ment, JRE 6.0 (which contains JVM 1.6). Most likely, Java is already installed on your computer. The version
of your Java installation can be checked from the UNIX and DOS Command Line using the command java
-version. The command will print a string like java version 1.6.0_05. If the Java version is earlier than
version 1.6, you should get the latest version of JRE from the Java download page:

http://java.com

The page contains downloads for the various platforms and instructions for the OT installation and deploy-
ment. One can also download the JRE software using the DOWNLOAD link that actually detects the platform in
use. If you run into problems with the installation you can ask your computing support to install it for you. It
is possible to install the JRE in your own directory space.

Below, in Sections 2.2 and 2.3, the details of the installation of the OT using Web Start and the tarball
installation are discussed. Independent of the installation method used, the OT will be installed with a default
configuration suitable for the general user. Details of the OT configuration are provided in Appendix A.

2.2 The Java Web Start Installation

With the Web Start method, stand=alone Java software (like the Observing Tool) can be deployed with a single
click over the network. If a network connection is available, the use of Java Web Start ensures that the most
recent version of the OT will be available to you. Provided JRE is properly installed on your platform, Java
Web Start provides a simple and transparent method for installing the OT.

2.2.1 Verifying Java Web Start

Installing and running the ALMA OT using Java Web Start requires that qJava Web Start is installed on your
computer (Java Web Start comes with JRE 6.0), and that it is properly configured. Furthermore, the browser
has to know to start up Java Web Start when a .jnlp file is downloaded. To verify that Java Web Start is
correctly working one can point the browser to:

http://java.sun.com/javase/technologies/desktop/javawebstart/demos.html

and try to launch one of the demos. In the case it does not work, you may need to configure your Web
browser. Please check the Appendix B for some browser configuration details.

2.2.2 Starting the OT

To download and run the OT with Java Web Start, please go to the ALMA Science Portal:
http://www.almascience.org

The OT is available under the Call for Proposals link. Clicking on the WebStart icon will download and
start the OT OT.jnlp provided that Web Start is configured correctly. In the case of Windows and Gnome 2.0,
and depending on your settings, an icon of the Web Start OT application is placed on the Desktop.

During the installation process you may well receive warnings that suggest that you should not install or run
the software you have just downloaded. This is because we do not yet have the means to certify officially our
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software. Please just go ahead and ignore the warnings! Similar warnings may appear when the OT application
is about to start.

2.2.3 Running the OT offline

If you have downloaded the OT and wish to run the software later when not on the network, then you may
do this from the Java Application Cache Viewer. You can start the Java Application Cache Viewer; this can
be displayed by running the command line tool javaws -viewer on most systems – remember that you may
need to specify the full path. The Java Application Cache Viewer will display Java applications that are locally
available. If you have downloaded the OT successfully earlier, the OT icon will be displayed in the GUI of the
Application Viewer. An example of what the Java Application Cache Viewer looks like is provided in Figure 2.1.

.

Figure 2.1: An example display of the Java Application Cache Viewer. The viewer displays the Java applications
that are available locally. If a network connection is available, a more recent version of an application (provided
it exists) can be downloaded and run.

Click on the ALMA Observing Tool icon and on Launch Offline. By doing so, Java Web Start will not
make a network connection and try to find a more recent version of the OT. Alternatively, when clicking on
Launch Online, a more recent version – if available – will be retrieved and launched. Please note that if running
in offline mode, the OT will still report the availability of a new version, if it exists.

2.3 Tarball Installation

2.3.1 Installation

In order to successfully run the tarball installation of the Observing Tool, you also need Java version 1.6.0 or
higher. The install steps are given below:

1. Download the OT tarball via the ALMA Science Portal:
http://www.almascience.org :

and store the tarball in the directory of your choice. Note that the tarball is available in .zip and in .tgz
format. Choose the one that is most convenient for you.

2. Unpack the tarball in the installation directory you have chosen in Step 1.

3. Read the README.txt available in the installation directory and follow the post-installation setup in-
structions contained therein for your platform.

The post-installation setup for Linux and Mac OS is as follows:
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> cd ALMAOT-Cycle0/setup
> ./Setup-Linux.sh
> cd ..

For Window the setup is:

> Go to the ALMAOT-Cycle0/setup directory
> Double click "Setup-Windows" (may read "Setup-Windows.cmd")
> Go to the ALMAOT-Cycle0 directory

2.3.2 Starting the OT

For both Linux and Mac OS, the OT can be started using the script that is in the directory in which you
unpacked the tarball distribution:

./ALMA-OT.sh &

If you’re on MS Windows Double-click "ALMA-OT" (might read "ALMA-OT.cmd").

Note, that you can also add the OT installation directory to your path and run the ALMA-OT-CommandLine.sh
script from anywhere. The script will issue a number of messages in your terminal window and finally start the
OT. Also the script will create a .almaot folder in your home directory, containing the user’s preferences for
running the Observing Tool and the log file.

The User Manual for the ALMA OT is available as on-line help and can be accessed via the Help button
in the Menu at the top of the OT interface. Alternatively, you can use the F1 key. The User Manual is also
available as a PDF document.

When running a tarball version of the OT, a log file, ot.log, is written to the .almaot directory. Note that
the file gets overwritten every time you start the OT. Therefore, if the log file contains useful information you
should save the file before re-starting the OT. When sending an error report, please include an attachment with
the log file to your message.

It is planned that a new release of the OT will be announced with every observing cycle, this containing the
most up-to-date information regarding the observatory capabilities. If a new version is available, the OT will
detect this and tell you to download the new version. If you are running the wrong version of the OT, it
will not be possible to submit your proposal and/or observing program! The Web Start installation
should automatically upgrade itself, but a new tarball will need to be downloaded if this is what you are running.
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Chapter 3

Basic Concepts

3.1 The ALMA Data Flow System

The ALMA Data Flow System (ALMA DFS) is a set of protocols, interfaces and tools that are developed by the
ALMA Observatory for linking the various processes in the observing process, e.g. Phase 1 proposal preparation,
submission and review; Phase 2 observing preparation, validation and submission; execution of science, technical
and calibration observations; data calibration and pipeline processing; quality control, data archiving and data
distribution. The Observing Tool is one of the ALMA DFS tools that has been designed to create a complete
observing project, i.e. to prepare an observing proposal for Phase 1 and to complete and submit an observing
programme during the Phase 2 process.

The ALMA OT layout is designed to reflect both the needs of the external user and of observatory staff in
terms of creating projects in a structured but flexible manner, and of the observatory in terms of what must
be created in order to schedule and execute observations most efficiently. There are some key definitions that
should be understood in order to use the Observing Tool most effectively in creating and submitting observing
proposals in the Phase 1 process, and to specify the observing programme information during Phase 2.

For obtaining observing time on ALMA and executing a scientific observation, the user needs to construct
an observing project. This observing project consists of the observing proposal for applying for observing time
(Phase 1), and the observing programme for specifying in detail how the observation will be carried out (Phase 2),
if time is awarded by the proposal review panels.

3.2 Phase 1 Observing Proposals

The first stage of applying for ALMA time is the creation and submission of an observing proposal; this is often
referred to as Phase 1. This will be subject to scientific and technical review by a system of proposal review
panels, the result of which will be a letter grade that will determine the likelihood of the project being awarded
time. The proposal must contain a scientific and technical justification, but will also include some administrative
information about the PI and Co-Is. In addition, the user must create Science Goals, constructs which capture
the basic scientific requirements of the planned observations and which are used to create the telescope runfiles
(Scheduling Blocks).

3.3 Phase 2 Observing Programs

After the successful application of a Phase 1 proposal and having obtained observing time, the telescope runfiles
(Scheduling Blocks) need to be created; this is often referred to as Phase 2. In most cases, these will be
automatically generated from the Science Goals that were defined at Phase 1. The OT will be used to retrieve
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the approved project from the ALMA Archive, the user will generate the SBs, and the project is resubmitted to
the archive.

For privileged users, it is possible to create a Phase 2 project by skipping the Science Goal stage and
constructing the ObsUnitSets and Scheduling Blocks directly. This is a complicated process and will not generally
be available to normal users.

3.4 Science Goals

The simplest method of creating Scheduling Blocks is by creating one or more Science Goals. These must be
created as part of an observing proposal, but may be skipped by privileged users. A Science Goal captures
the basic scientific requirements of a project (e.g. desired sensitivity, angular resolution, largest angular scale of
source) and so does not require detailed knowledge of how ALMA works or how the observations are actually
run. The OT contains a number of tools that aid in the process of filling the necessary information and will warn
the user if invalid parameters have been entered.

If a proposal is awarded time, the project is retrieved from the archive and the SBs are automatically generated
from the Science Goals.

3.5 Scheduling Blocks

Scheduling Blocks are the key executable units of a project and contain all information necessary to execute a
single observation. As such, each SB will be a self-consistent set of observations, including calibration information.
The SB contains detailed information about the receiver and correlator setup, integration time, telescope pointing
parameters, etc., but also scheduling requirements and time constraints. A SB can be repeated several times to
achieve the desired sensitivity or to reach the maximum allocated time.

By providing the technical information of the observing programme by creating Scheduling Blocks, with-
out using a Science Goal, the user has more control of the actual observing process and can fine-tune the
various and many parameters and experiment with complicated setups. It requires good knowledge of (sub)mm-
interferometry in general and of the ALMA system in particular. Hence it is intended for experienced observers
and for observatory staff for developing and testing new observing modes.

3.6 ObsUnitSets

Depending on resolution and/or dynamic range goals, and perhaps to ensure good (u, v) coverage, a science
target might require more than one SB. An example would be an extended object that requires both ALMA and
the ALMA Compact Array (ACA) – each would have at least one SB. Please note that even if a single SB is
adequate, this may be repeated many times in order to produce the required sensitivity.

The SBs are grouped within ObsUnitSets (OUS). One of the main functions of an OUS is to trigger the
pipeline when all the SBs within have been observed. It therefore contains information about the data processing
parameters, although these are not yet used. It will also eventually be possible to define relationships between
the SBs (for instance execute SB A before SB B).
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Chapter 4

Overview of the Observing Tool

As explained in Chapter 3, an observing project starts with the creation of a Phase 1 observing proposal that
is submitted to the observatory via the ALMA Archive. If the proposal is approved by the ALMA Proposal
Review Committee, it then becomes a Phase 2 observing programme. The information previously provided in
the proposal’s Science Goals is then used by the OT to prepare the Scheduling Blocks that will actually be used
at the telescope to collect the scientific data.

This chapter provides a brief overview of the OT and the features with which you should have some familiarity
before beginning to prepare your Phase 1 proposal or Phase 2 observing programme. Detailed information on how
to create and to submit an observing project and the corresponding Phase 1 proposal and Phase 2 programme
using the OT is described in detail in the following Chapters 6, 7 and 8.

Once you have successfully started the ALMA OT application, the OT main GUI will be displayed in your
screen. The appearance of the main OT GUI is similar to that shown in Figure 4.1.

Figure 4.1: The Observing Tool main GUI.
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4.1 Help

4.1.1 Manuals

At the top of the OT GUI, at the right, you will find the Help button. This provides access to the User Manual,
the Reference Manual and general information about the OT. The User Manual (this document!) provides
comprehensive information on how to create a project, either a Phase 1 proposal or a Phase 2 programme. The
Reference Manual provides further details about the buttons and fields in the OT.

In addition to the User and Reference Manuals, the OT also provides built-in aids for information:

• All fields in the OT are equipped with tooltips that provide information about usage and intentions of
the fields and the range of legal values that can be entered. To display this information, simply move the
cursor over the fields, checkbox, or drop-down menu; The tooltip information for the field then becomes
visible. How long the tooltip information is shown can be set via File → Preferences in the Appearance
tab. See below in Section 4.2.3.

• The OT includes a contextual help function. Many of the panels in the forms editor panel contain question
mark icons which can be clicked and which bring up the relevant part of the Reference Manual. In addition,
clicking on the Question Mark icon in the Toolbar at the top of the OT allows the cursor to then be clicked
anywhere in the OT and the relevant help displayed.

• The User and Reference Manuals, as accessed through the OT, contain a table of contents, are fully indexed
and have a search facility. A list of favourites can also be created.

4.1.2 About the OT

Help → About... displays a window that includes multiple tabbed panels for information about ALMA and the
OT, as well as acknowledgements, credits, software license and version information.

4.2 The OT Main Graphical Interface

The OT main GUI contains three major components: the Menu at the top, the Toolbar below this that contains
the most frequently used functions in the Menu and below this, a number of different panes that show information
about the project and which allow various parameters of a proposal/observing program to be defined. These
panes take up most of the OT’s screen space.

4.2.1 GUI Parameter Fields

The OT contains a large number of text and numerical input fields. Some of these numerical fields are intended
for entered quantities with units (e.g. angles, temperatures, fluxes, etc.). For all these fields, the OT displays a
tooltip when the cursor is placed on a button of an input field. The display duration of the tooltip can be set
using File → Preferences .

Units for the parameters fields can be selected from a drop-down list located to the right of the input field.
For these fields, changing the units with the mouse whilst holding down the ALT key will cause the quantity
to be automatically converted to that unit. Changing the unit without pressing the ALT key will change the
unit only. For example, if you have an angle of 1.0 arcmin, changing the arcmin to arcsec in the drop down list
without the ALT key will result in an angle of 1.0 arcsecs. Changing the arcmin to arcsec on the drop down
whilst pressing the ALT key will result in an angle of 60.0 arcsecs.

When a text field is selected (with the cursor or by tabbing into it), then by default the text in the field will
all be selected. Typing anything will replace the value in the field. Changing this so that new text is initially
inserted into fields rather than replacing a field, can be done via File → Preferences.
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4.2.2 GUI Features

The use of OT GUIs heavily relies on selecting and manipulating items by means of standard GUI conventions
such as mouse-driven positioning of the cursor or mouse-button clicking to select elements. The edit options
Cut, Copy and Paste, as well as the options to "Drag and Drop" and other operations on items in the Project
Tree, are all implemented and work basically in the same way as on most windows-based platforms. They work
within a project and between projects (including the Template Library). To drag/move and drop: select with
the left mouse button, then drag with button held: drop into an appropriate location. To drag/copy and drop:
select with CTRL-left mouse button, then select the location for the copy. Note that for read-only resources,
such as the Template Library, all actions are copies, never moves.

Items that can be dragged/dropped include:

• Science Goals,

• Individual nodes of Science Goals,

• Targets,

• Resources.

Clearly, it is only possible to drop/paste these into appropriate places i.e. you cannot drop an ObsUnitSet
into a SB, or a Resource into a Science Goal. Also, it is not possible to move SBs or ObsUnitSets, either within
the same project or between the Template Library and a project. Instead, such an item will be copied. The copy
of an SB or ObsUnitSet will have the term "Copy of" prefixed to its name.

4.2.3 Menu and Tool Bar

The Menu gives access to a variety of OT functions and tools. These are:

• File: This contains submenus for managing projects: to create new proposals (Phase 1) or programs
(Phase 2), to open and save projects locally, for using the ALMA template library or to use a project as
a template, to validate a project, to submit projects to the ALMA Observatory, and to exit the OT. The
user preferences can also be changed.

• Edit: This contains project editing functions (cut, paste, delete, rename) and allows the addition/deletion
of projects components like Science Goals or SB parameters. Note that the availability of the function
depends on which component of a project is selected.

• View: This allows the display or otherwise of the Feedback and Overview panels. It can also be used for
displaying the Template Library in the Project Tree structure pane.

• Tool: Various tools are accessible here including the Calibrator Selection Tool, the LO Configuration Tool,
the Calibration Time Estimate Tool and the Sensitivity Calculator. One can also create SBs from Phase
1 and Phase 2 Science Goals, generate a PDF summary of the proposal and disable edit protection.

• Search: This allows you to jump between the problems reported in the Feedback pane (see below).

• Debug: This allows you to enable/disable debug facilities. It is only available for privileged users.

• Help: This gives access to the various items of help and general information about the OT.

Figure 4.2: The Menu bar and Toolbar are displayed at the top of the OT window.

The Toolbar contains buttons for executing frequently used OT functions and tools. The following buttons
are included. Note that a button is only enabled if it can be applied to the selected node in the project tree.

17



• New Proposal (Phase 1): This creates a new observing (Phase 1) proposal.

• New Program (Phase 2): This creates a new observing (Phase 2) program.

• Open Project from ALMA Archive: This will retrieve a project from the ALMA Archive.

• Show the ALMA Template Library: This will display the Template Library in the Project Structure
pane.

• Open Project from Disk: This will allow you to open a previously-created project from disk.

• Save Project to Disk: This will automatically save your project for disk, overwriting the previous version
and prompting for a filename if not already defined.

• New Phase 1 Science Goal: This will add a Science Goal to your proposal.

• New Phase 2 Science Goal: This will add a new Science Goal into a Phase-2 observing program.

• Generate SBs for the Selected Goal: This will automatically create SBs from a selected Science Goal.

• Add ObsUnitSet: This will add an OUS to a Phase-2 program.

• Add Scheduling Block: This will add an SB to a previusly created ObsUnitSet.

• Sensitivity Calculator: This will launch the ALMA Sensitivity Calculator in a GUI.

• ALMA Calibrator Selection Tool: This will launch the ALMA Calibrator Selection Tool in a GUI
(Phase 2 only).

• Validate: This will validate the project i.e. check for errors and issue warnings.

• Go to previous Problem: This will allow you to view the previous problem found by the validator.

• Go to next Problem: This will allow you to view the next problem found by the validator.

• Help: This will give access to the various items of help.

4.2.4 The OT Panes

The area below the Menu bar and Toolbar is divided into a number of panes. Each has a couple of tabs that
determine which information is displayed or how it is displayed. The position of the tabs (bottom or top) can
be controlled via the Appearance tab in the Preferences menu. The panes can be collapsed and expanded by
the small arrows on the boundaries of the panes. When resizing the full OT application window only the main
Editors pane will grow.

Below follows an overview of which panes are visible in the OT. Details about the panes will be provided in
the chapters about Phase 1 proposals and Phase 2 programmes.

• Project Structure: This shows the overall structure of the project. Using the tabs at the bottom or top
one can select to display the structure of the observing proposal or of the program. The project pane can
also display the content of the ALMA Template Library.

• Editors: This contains the forms for entering spatial and frequency information of the observations in the
project. The tabs can be used to choose between entering the data using the Visual Spatial or Spectral
Editors or via a plain form.

• Feedback: This provides feedback after validating the project. When running the validator the pane will
become visible and displayes errors and warnings found. The Feedback pane has three tabs: Problems,
Information and Log.

• Overview: This window outlines the steps for preparing a new science proposal for submission and for
further fine tuning of the observation program. Clicking on the overview steps will display the contextual
help.
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The Project Structure Pane

As described earlier, an ALMA project consists of two distinct phases, proposal preparation (Phase 1) and
observing program preparation (Phase 2). The structure of each is shown in the Project Structure pane located
on the left of the OT. Which one is active is indicated by the tab at the top of the pan and by the colour of the
header bar.

When working on a proposal, all panes have a green header and the Proposal tab is highlighted. The same
colour is used for the Phase-1 steps in the Overview pane. Several folders are used to enter various information
about the proposal and Science Goals can be added that describe the scientific aims of the proposed observations.

When working on an observing program, the Program tab is enabled and all panes have blue/grey colour
header bar which is also used in the Overview pane for the Phase-2 steps. For Phase 2 the user basically has
the choice of creating the details of the observations via Science Goals or by creating SBs directly. The latter
possibility provides more control over the telescope configuration and the observing setup for the scientific targets
and calibrators. However, it requires detailed knowledge of ALMA and interferometry and is only available to
privileged users. If Science Goals have been created, Phase 2 SBs can be created automatically using the SB
Generator available via the Toolbar. The SBs created by the generator are added to the Science Goal as an
additional node.

The Project Structure pane can be split in a number of sections. The top section always contains the project
that is being worked on (either the Phase 1 or the Phase 2 tree). In the sections below, templates can be loaded,
either from the ALMA Template Library, or from an existing project locally. You can display several projects in
parallel. Note the grey background of the template sections, indicating that the content is read-only and cannot
be changed. With the OT, you can use the template setup for copying and use for the project.

Figure 4.3: The Project Structure Pane. Visible is the structure of a Phase 1 program with two Science Goals
(top) and another project that has been loaded as a read-only template (bottom).
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To activate a project or a template, click anywhere inside it in the Project Structure pane. This will visually
highlight the project and cause the name of the project to appear in the title bar of the Observing Tool main
GUI. Note, that only one project can be active at any given time. Using projects that are stored locally you can
create a personal library project in which you collect all of your most frequently-needed project components.

The Editors Pane and the Editor Types

The Editors pane is used to enter information into the various nodes of the Phase-1 or Phase-2 project e.g.
the Science Goals, Scheduling Blocks, etc. It has three tabs which give access to the Spectral, Spatial and
Form editors. Whilst the Form tab is always selectable, the Spectral and Spatial tabs only become active when
appropriate. It is possible to select which tab is highlighted by default using the Appearance tab of File →
Preferences; all the information in the Forms editor is also displayed in the corresponding Spectral or Spatial
tab.

The Spectral tab is used to visualise the frequency setup of a project, including the receiver bands, sidebands
and spectral windows. The atmospheric transmission curve can also be plotted and spectral lines overlaid. In
addition to the visualisation, the Spectral tab also shows the receiver and correlator related fields that are visible
in the Forms tab.

The Spatial tab is used to visualise the field setup of the project, either by downloading an image from
one of many image servers or by loading a local FITS file from disk. Using the cursor, pointing positions and
rectangular mapping areas can be defined.

The Form tab displays the form corresponding to the node that has been selected in the project tree. Note
that the name of the forms editor changes depending on which part of the project tree is currently selected.
While the forms for Science Goals are relatively simple, more complex and elaborate forms need to be completed
when creating a Scheduling Blocks; the correlator configuration is particularly complicated.

The Feedback Pane

The Feedback pane reports errors and warnings to the user and makes suggestions for optimising the proposal or
program. The feedback can be inspected in three tabs: Problems, Information, and Log. The Feedback pane is
made to appear automatically when the validation command is executed. Each of these tabs provides different
views of more or less the same information. Clicking on the >> symbol in the Information tab will reveal the
error/warning list.

Errors must be fixed or else the project will not validate and will not be able to be submitted to the ALMA
Archive. Warnings are meant to draw your attention to issues that might be of concern, but which are not
actually wrong.

The Overview Pane

The Overview pane at the bottom of the OT window outlines the steps for the preparation of a new science
proposal and for the submission of an observing program for an approved project i.e. Phases 1 and 2. Only one
is displayed at a time; which one can be selected using the arrow in the bottom right corner.

In each of the panels the user can click on each of the steps; this causes the Contextual Help box to display
the instructions on how to complete the chosen step. This explains where to find the appropriate menu options
or toolbar icons, as well as providing shortcuts for performing the relevant task. This pane can be displayed at
all times, but as it is mainly meant for novice users, it can be minimised using the arrows in the corner.

4.3 OT Configuration

The ALMA-OT supports a number of layout and display configurations that can be selected by the user. The
most basic of these is that you may collapse the various panes in the main GUI window and/or change their size.
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Figure 4.4: The Overview panes for Phase 1 (top) and Phase 2 (bottom). The Contextual Help on the left
reflects the project phase that is selected on the right.

Collapsing can be done via the small arrows next to the pane borders; the border themselves can be moved using
the left cursor button. These changes are automatically maintained the next time you run up the tool (stored
in the $HOME/.almaot directory.

Additionally, using File → Preferences window, a number of tabs are displayed that allow you to change
the OT’s behaviour and appearance. These are: Appearance, Colours, Dialogs, Connection, Advanced and
Telescope. The Preferences GUI is displayed in Figure 4.5.

Figure 4.5: The GUI of the OT for setting the user appearance preferences.

4.3.1 Appearance

• Tab Placement: Used to specify tabs at the bottom or the top of panels.

• Font Size: Used to change the size of the fonts used in menus and labels.
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• Mouse-over Tooltips: Used to set the time duration of the tooltip displayed. The default is 4 sec. Any
tooltips disappear when you click in or move out of the field.

• Science Goal Summary View Used to choose between a full display of the Science Goal parameters or
a one line summary per Science Goal.

• Preferred Editors: To select the preferred editor (Forms, Spatial or Spectral).

• Text Forms: To enable/disable the text selection when putting the cursor into a fields.

• Perspective: Here you may choose between two different layouts of the panels within the OT.

• Look and Feel: Select a “Look and Feel” for the OT window decorations. Note that if a user’s preferences
file specifies the older Skin option, the default (Metal) will be used instead and the entry in the preferences
file migrated to the default. Note that the pane collapse buttons as well as other graphical objects may
depend on the selected Look and Feel.

4.3.2 Colours

Here the user can define which colours to use for the various aspects of the OT, including the Phase 1 and Phase
2 colours that make it easy to recognise which phase of a project is being worked on. The Colour tab can also
be used to adjust the display of spectral information, in particular in the Visual Spectral Editor. A display of
the colour preferences is shown in Figure 4.6.

Figure 4.6: Display of the colour choices in the Colour tab of the OT Preferences.

4.3.3 Dialogs

The Dialogs tab in the Preferences panel, as shown in Figure 4.7, allows users to enable or disable the various
pop-up dialog messages that appear. Inexperienced users are advised to have ticks in all tick mark boxes, i.e.
to enable all dialogs. Note that some names and description are a little cryptic and not very readable for users
unfamiliar with the Observing Tool.
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Figure 4.7: The display of the dialogs pop-up windows can be enabled/disabled via the Dialogs tab in the OT
Preferences.

4.3.4 Connection

In the Connection tab, the user authentication details that are required for submitting or retrieving a project
to/from the ALMA Archive can be entered. These settings are saved as a user preference and therefore persist
across sessions. The username/password details may be changed at anytime. Browsing the Archive (in a retrieve
operation) will, by default, only show the projects for which the user has read permissions. The archive to
connect to is selectable by privileged users.

4.3.5 Advanced

Items under the Advanced tab can be used to enable the advanced user features, control the availability or
visibility of the debug menu, and enable/disable write protection of ObsUnitSets. The availability of the advanced
user features (privileged operations) requires network access so that the user’s role (as set in the user database)
can be verified. This enables various features of the OT that are otherwise hidden or disabled (creating a
commissioning project, submitting a project as new, etc.)

4.3.6 Telescope

The Telescope tab is only available to privileged users and allows one to modify the telescope (Early or Full
Science) and correlator (number of quadrants) characteristics that the OT uses.

4.4 Project Validation

The rather extensive set of science requirements make ALMA a very flexible instrument, providing a large
number of observing modes and strategies to the astronomical community. In order to ensure that all users
can explore the capabilities of this instrument, great care has been taken to have an OT in which specifying a
proposal or an observing project is relatively simple, and which can be used effectively even by non-specialists
to perform interferometry techniques. Nevertheless, because of the large amount of observing possibilities,
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Figure 4.8: The connection tab in the Options GUI. Here the user authentication and connection details can be
entered.

specifying an observing program can be complicated, in particular when using the expert mode and/or exploring
a non-standard observing mode for planning observations.

In order to ensure that the user’s specifications for an observation are possible with ALMA, the OT provides
a number of validation checks. Part of the validation is performed automatically when observing parameters
are entered: invalid inputs in the fields will be coloured red as a result of on-the-fly validation. In addition,
validation for checking overall consistency and completeness should be performed manually once all the required
information has been entered.

Proposals and observing programs will only be accepted by ALMA when the validation does not report
errors. Therefore, it is essential to check the validity of the input constantly and to run the validator prior to
submission. Note that even if a manual validation is not run by the user, it is always run automatically as part
of the submission process. Therefore, an invalid proposal can never be submitted to the ALMA Archive.

A comprehensive description of proposal and project validation can be found in Chapter 11.2.

4.5 Exiting the OT

The OT can be stopped in the standard way via the menu bar at top of main interface of the Tool: File → Exit.
The other, less elegant, way of leaving the tool is by killing the OT window using the button provided by your
operating system (found together with the maximise and minimise buttons). With both methods you will be
asked if you really want to exit and possibly lose unsaved work.
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Chapter 5

Tools

The OT has a number of tools to help users in planning observations: a Calibrator Selection Tool, an LO
Configuration Tool, a Calibrator Time Estimate Tool, a Sensitivity Calculator, and a Spectral Line Selection
Tool. There is also the ALMA Template Library.

5.1 The ALMA Template Library

The purpose of the ALMA Template Library is to provide a set of Science Goals for a range of projects that
illustrate what is possible with ALMA. These are read-only, but can be inspected for tips on how to construct
Science Goals. They can also be copied and pasted into a project that is under construction. At this point the
Science Goal becomes editable and can be altered to fit the scientific aims of a new project.

5.1.1 Access the Template Library

To access the ALMA Template Library use File → Show ALMA Template Library. The template library will
appear at the bottom of the Project Structure Panel. Note that you might have to scroll down in that panel to
see all of its content.

The Template Library contains a number of Science Goals which should be immediately visible. A small
description will appear in a tooltip when the cursor is moved over each of the Science Goals. Each Science Goal
can be inspected in detail by clicking on it and revealing its contents; the non-editable details will become visible
in the Editors pane. An overview of the ALMA Template Library is visible is Figure 5.1.

5.1.2 Copy a Template Science Goal to your Proprosal

To copy one of the template Science Goals to a proposal, click on the Science Goal in the ALMA Template
Library panel. After selecting the Science Goal use Edit → Copy or the right mouse button. Next, in the Project
Structure pane, select the Proposal node to which the Science Goal should be added. Click on this and select
Edit → Paste or the right-mouse button. Alternatively, the Science Goal in the ALMA Template Library can be
selected and dragged and dropped into the Proposal folder in the Project Structure pane. The pasted Science
Goal is now part of the proposal and can be edited.

5.1.3 Save and Open a Project as a Template

Once the proposal is done, it can be used as a local template for later use. This is done by File → Save or File →
Save As. To open a project that is stored locally as a template (in read-only mode), use File → Use Project As
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Figure 5.1: The ALMA Template Library.

Template → From File.... The project will then open up in a separate template library panel below the ALMA
template library panel.

5.2 Calibrator Selection Tool

This is selected via the Toolbar or by choosing Tool → ALMA Calibrator Selection Tool.... The calibrator query
dialog is used to select sources from the ALMA calibrator catalogue and to fine-tune calibrator selection criteria.
It is shown in Figure 5.2. Please note that this tool is not available for constructing Phase-1 Science Goals.

Calibrators are found by matching a set of search criteria, consisting of a set of minimum and maximum
values for the frequency, flux and time since last observation, and the centre position and search radius fields
for a cone search within the circle of the radius specified, centered on the Right Ascension and Declination. By
default, these fields are all set to zero and therefore disabled and a minus sign icon is displayed. To enable a
constraint, enter a non-zero value into a field; a plus sign icon is displayed.

Once you have entered your desired search constraints, the set of calibrators that currently match your
constraint can be found by clicking the Submit Query button. The matching calibrators will be displayed in the
table below. Results can be sorted by column by clicking on the column header.

Although the tool can be used to query for calibrators, adding calibrators can only be done in a Scheduling
Block of a Phase 2 Observing Program. If so, the button Select As... will be enabled that provides you with a
dialog box to further specify usage of the calibrator after its selection. The dialogue box consist of two parts.
With Calibrator type one can specify for which calibrations the selected calibrator is to be used (amplitude,
phase, etc.). On the right the user can specify which SpectralSpec should be attached to the calibration source.

For the selected calibrator, the Calibration Tool will add one source to the Target folder and attach a
FieldSource and an Observing Parameters set. On the right in the dialog box, Copy to new setup will create a
copy of the science source’s SpectralSpec and attach this to the calibration source. Link to same setup will attach
the science SpectralSpec to the calibration source. Do nothing will not create a SpectralSpec for the calibration
source. Note that a SpectralSpec can only be copied or created when it exists.

For details how to add a calibration source to a Scheduling Block please see Section 8.3.2.

5.3 LO Configuration Tool

Selecting Tools → ALMA LO Configuration Tool in the Menu will launch a separate window which provides an
interface to the ALMA LO Configuration Tool. This is an experimental tool and intended for expert users only.
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Figure 5.2: The Calibrator Selection Tool.

It implements the same algorithm which will be used to set up the backend electronics when the Scheduling
Block is run at the telescope.

Upon clicking the Calculate LOs button after having defined the receiver type, the LO1 (optional) and
sideband specifications in the Settings panel, the tool will display the various parameters in the TuningParameters
panel.

The hardware does not always allow all frequencies to be set precisely as requested. The weight parameters
are used to apportion the errors accordingly. The sideband preferences allow selection of the 1st LO sideband.
A choice of NoPreference will try to use both sidebands when supported by the hardware. Choosing a specific
sideband will eliminate the other from the solution set.

5.4 Calibration Time Estimate Tool

This is a relatively recent addition to the and awaits detailed documentation. The purpose of the tool is to
experiment with the parameters that are used by the OT to calculate the calibration time required per Science
Goal. It does not affect the observations at all – it has mainly been used by the developers to test the calibration
time algorithms.

5.5 Sensitivity Calculator

The ALMA Sensitivity Calculator (ASC) is launched by either clicking on the button in the Toolbar or by selecting
Tool → Sensitivity Calculator.... We give here only a brief description of this tool; a more in-depth guide to the
ASC can be found in the Documents section of the ALMA Science Portal (http://www.almascience.org).

After having defined the input parameters (Observing Frequency, Bandwidth, Water Vapour Column Density,
etc.) in the common area in the upper part of the interface, using the number of antennas and required sensitivity,
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Figure 5.3: The LO Configuration Tool.

the tool calculates the integration times for the Main (12m Array) ALMA Array, for the ALMA Compact Array
(7m Array) and for a Total Power Array. The tool also provides the inverse facility, i.e. for estimating the
sensitivities given an input integration time. The layout of the calculator is displayed in Figure 5.4.

In the GUI, the user has to specify the bandwidth per polarization; multiplying this by the number of
polarizations (Single or Dual) gives the effective bandwidth. Sensitivity can be specified as a flux density if the
unit is Jy or as a brightness temperature if the unit is in K. If a flux density sensitivity is entered, a brightness
temperature equivalent is displayed in the following grey field and vice versa. Note that if the sensitivity is
entered in temperature units, the angular resolution must also have non-zero value in order for the calculator to
work! For Cycle 0, the angular resolution corresponding to one of the two configurations should be chosen (as
displayed on the Control and Parameter page of the Science Goal).

System temperature and atmospheric parameters are displayed for the specified frequency. There are 7 choices
of water vapour (PWV) data: 0.4722 mm, 0.658 mm, 0.9134 mm, 1.262 mm, 1.796 mm, 2.748 mm, and 5.184
mm; these correspond to the octiles measured over many years at the ALMA site. If Calculator Chooses is
selected, an appropriate choice will be made based on the entered frequency i.e. Band 9 observations must be
made in conditions with low water vapour.

Finally, with the Integration Time Unit Option the output unit for the integration time field can be
specified when using the Calculate Integration Time option. If Automatic is chosen, the tool itself selects
the appropriate unit. The current unit can be enforced in subsequent calculations using Keep displayed unit
whilst specific units can be selected using In sec, In min, In hour and In day.
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Figure 5.4: The ALMA Sensitivity Calculator.

5.6 Spectral Line Selection Tool

The ALMA Spectral Line Selection Tool contains the rest frequencies of millions of spectral line transitions that
are contained within NRAO’s Splatalogue. A subset of the Splatalogue is packaged with the Observing Tool,
which should be sufficient to select some of the most commonly targeted transitions. If network connectivity is
available, access to the complete catalogue becomes possible using the online search functionality. The tool is
launched from within a Science Goal using either the Select Lines to Observe... or the Select Lines to
Overlay... buttons. Within an SB it is launched via the Line Catalogue button.

When the transition selector dialogue is launched, the offline spectral line catalogue is displayed and every
transition in the offline catalogue is available for selection. Specific transitions can be located by using the
controls in the left-hand panel to set your search criteria. Transitions are matched by species or transition title
by typing into the Filter/Species input box, and matched by frequency and ALMA instrument band by dragging
the range sliders or using the frequency input boxes. Note that the frequency slider refers to sky frequencies.
Filtering is also done on sideband availability, maximum upper-state energy of the transition and on collections
of popular molecules.

The Filter/Species filter operates on substrings, so an input of CO will match all species containing CO
regardless of where the CO molecule is found (ie., CO, (17)OCO, and c-H2COCH2 are all positive matches).
The instrument band sliders, frequency sliders and frequency input boxes are all linked, so that adjusting the
target instrument band also alters the matched frequency range, and vice versa.

Below the Filter/Species field is a checkbox (Include description in search), which when checked
includes the transition description in the search. With this option enabled, a search can be made by transition
name rather than formula, e.g. ’water’, ’carbon monosulfide’, ’cyanobutadiyne’, etc. Matching descriptions can
occasionally obscure desired matches (e.g. searching for ’CO’ also matches hundreds of reCOmbination lines),
in which case it can be disabled. The same matching rules described above apply to descriptions too.

The spectral line selector accepts wildcards, which are entered with the ’*’ symbol. For example, searching
for ’CO’ matches transitions whose originating species begins with CO, e.g. ’CO v=0 1-0’. Entering ’*CO ’
matches transitions with CO at the end of the species, such as ’CCCO’ and ’(CH3)2CO’. Multiple wildcards can
be used; for example, searching for ’*CO*’ matches molecules with CO anywhere in their molecular formula,
such as ’t-DCOOH’.

Note that online searches do not handle wildcards, and the Search Online button will be disabled whenever
a wildcard is entered. Once the additional lines have been retrieved from the network, wildcard searches can be
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performed on the newly-expanded catalogue as normal. Also, network searches are not as advanced as searches
of the OT catalogue. Network searches can only match transitions by species and frequency, not description or
quantum numbers. For example, searching for ’CO’ in band 3 will give a result; searching for ’carbon monoxide’
or ’CO 1-0’ will not.

Figure 5.5: The ALMA Spectral Line Selection Tool.

The table with transitions show the rest frequency as well as the sky frequency which is calculated using the
source velocity when the selector dialog is launched. Clicking on the column headings Transition, Frequency,
and Catalog will cause a sort of the table entries so that they are ordered by the entries in that column. And,
after the first such click on any column heading, an up/down arrowhead does appear and the sort can be made
to be ascending or descending.

If your desired line cannot be found in the offline catalogue, it may exist in the more extensive online catalogue.
The online catalogue can be queried by clicking the Search Online button; the query will request transitions
originating from the species given in the Filter/Species box whose frequency is contained within the frequency
limits. The results of the query will be added to the list of selectable transitions, and will persist as part of the
offline database for your observing tool session so that repeat searches need not be submitted.

Having located your target transition in the available transitions table, select the transition and return to the
observing tool by double-clicking the appropriate row. Multiple transitions can be selected in some contexts, for
example when adding lines to the Spectral Visual Editor or selecting multiple spectral elements. In this case,
the list of selected transitions is compiled by double-clicking a chosen row or by selecting rows from the available
transitions and clicking the Add to Selected Transitions button. Likewise, transitions can be removed from the
selected table with a double-click or by selecting rows and clicking Remove from Selected Transitions.

5.6.1 Sideband Filter

A new and experimental Sideband Filter restricts the list of available lines based on the lines that have already
been selected. The default behaviour of the sideband filter is different depending on whether you have launched
the Spectral Line Selection Tool for selecting or overlaying lines. If you are choosing lines to enter into the
spectral window table, the filter is enabled by default. If you are overlaying lines, the filter is disabled by
default. As this is a new feature, it can be disabled using a checkbox. We now briefly explain how this filter
works.

An ALMA receiver has two sidebands with fixed widths and separations – all of the defined spectral windows
must fit into the sidebands as only then can a tuning solution be found. Entering a single line defines a range of
frequency space where other lines could be added. For example, if the OT has automatically placed this line in
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the upper sideband, the available frequency space will not only include the lower sideband, it will also include
what would have been the upper sideband had the OT instead placed the line in the lower sideband! Once a
second line is defined that sits in one of the possible other sidebands, the “third” sideband disappears. In general,
as more lines are defined, there is less and less freedom as to where additional lines can be placed. Note that if
the first line defined is close to the edge of an ALMA band, the “third” sideband will never arise as the line can
only go in the upper or lower sideband.

We again note that this is an experimental feature that has not been tested as much as we would like. We
hope that it will be useful, but please be careful when using it.
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Chapter 6

The Phase 1 Observing Proposal

This chapter guides you through the steps that you need to take to create a Phase 1 proposal. To follow the
descriptions given in this chapter, it is recommended that you have an open OT session in front of you at the
time of reading it.

In principle there are a number of possibilities to start work on a Phase 1 observing proposal:

• Start with a complete new project using File → New Proposal.

• Load an existing and possibly incomplete Phase 1 proposal by opening the content of an ALMA OT project
file (File → Open Project → From File..., see Section 11.1).

• To retrieve a project from the ALMA Archive using File → Open Project → from ALMA Archive....
Obviously, this option requires a network connection to the ALMA Archive and permissions to read from
the Archive.

• To open the ALMA Standard Library via File → Show ALMA Template Library and use the Phase 1
information of an available project template.

• To open a locally available project and show this as a template via File → Use Project as Template and
use the Phase 1 information of this project.

When loading Phase 1 information, either locally or from the ALMA Archive, dialogue boxes will appear
that warn about possible overwriting of an existing project and to select the project file to be read.

6.1 Create a Phase 1 Proposal

In particular for non-interferometric experts, the OT provides an easy way to create observing proposals without
having the need to specify large amounts of observing detail. For standard observations, this is done by defining
Science Goals, each of which contains the basic scientific aims of a project. Often a single Science Goal will
suffice, but due to various restrictions on these (e.g. only one ALMA band can be included), more than one
might be necessary. Each Science Goal consists of a series of forms to specify spatial, spectral and a number of
control parameters, as well as some information for the calibration observations.

The first action to create a Phase 1 proposal is to provide some generic information about the project. This
is done in the Project form that is visible when selecting the Project node. The fields in the panels Principle
Investigator and Main Project Information are to be filled in. Project Note and Advanced Options are for
privileged users only. The Project form is visible in Figure 6.1.

In the Project Structure pane, a Proposal folder will be visible underneath the top Project node. Within
this is a Planned Observing folder to which Science Goals can be attached. At the top of the project tree,
the status of the Proposal is visible. For newly created proposals it will say Unsubmitted Proposal; proposals
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Figure 6.1: The Project form with the Principle Investigator, Main Project Information and Advanced Options
panels.

that have already been submitted will show Submitted. The latter should be considered as a warning. If this
message is visible, submission of the proposal will overwrite the previous submission even if every single detail
of the proposal has since been changed! Please see Section 11.3 for more details of what can go wrong during
the submission process.

6.1.1 For ALMA Staff Only

The panel Advanced Options (Staff Only) contains the field Version for the version of the project and buttons
for the project mode. These can be Manual, Simulation, Calibration and Commissioning. Calibration Mode
should be checked when it is an Observatory Calibration project. At present this will only make a difference to
the project code that is generated on submission; there are no other consequences. The CSV team may choose
to use it if they wish. Commisioning Mode should be checked if this is a Commissioning project used by the CSV
team. This indicates to the scheduling software that this project is not a normal project and will not follow the
normal project lifecycle.

6.2 The Proposal Information Form

When the Proposal node is selected, the Proposal Forms editor is visible. This consists of four panels: Proposal
Information, Investigators, Science & Technical Case and Observatory Use Only. A number of fields are spread
over these panels and allow the user to enter information about e.g. the proposal title, cycle, abstract, proposal
type, the name of the PI, Co-I, etc. The Science and Technical Justification can also be attached.
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An example of an empty Proposal Information panel is shown in Figure 6.2. Most of the required information
is straightforward. Regarding the Proposal Type, the user can presently select from two choices:

• Standard: for proposals that require normal amounts of observing time (<100 hours).

• Target Of Opportunity: For proposing the observation of an unpredictable sudden astronomical event.

Note that after the first submission of a project, this choice cannot be changed.

Figure 6.2: An example of the Proposal Information panel of the Phase 1 proposal Form.

A project has one Principal Investigator (PI), and optionally can have any number of Co-Investigators.
Clicking on Select PI... and Add CoI... will start-up the Investigator Search GUI which allows you to
search for and select users from the ALMA user database.

Users can be identified by their name, email or ALMA ID. To find matching users, select which attribute
should be searched from the drop-down list, enter a valid constraint into the text field and click Find Investigators.
If the constraint you have entered is invalid, it will be highlighted in red and the Find Investigators button
will be disabled. A valid constraint consists of:

• Name: at least 3 characters.

• ALMA ID: at least 3 characters.

• Email: a valid email address.

Users matching your constraints will be shown in the dialog’s results table. Select the row containing the user
you wish to choose, and click Set PI or Add CoI; the button label changes to describe what the operation will
actually do), or click Cancel to terminate the session. In case only one result is returned it will be automatically
highlighted. When adding CoIs, multiple rows can be selected, which will add all selected users as CoIs when
the Add CoI button is pressed. To remove a CoI from your project, select the table row containing the CoI (or
multiple rows if multiple CoIs are to be deleted), and click Remove CoI.

Multiple queries can be performed in one go by entering search terms separated by commas. For example,
the users with ALMA IDs john, paul, george and ringo can be retrieved in one pass by searching ALMA ID for
john,paul,george,ringo. Figure 6.3 provides an example of the Investigator Selector interface.
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Figure 6.3: The Investigator search dialog to select the Proposal investigators from the ALMA users database.

The button Add from Proposal... in the Investigators panel is used to import investigators from another
project. Clicking the button launches a file selection dialog; select the project containing the investigators to
import and they will be merged with the current project.

Once a PI has been selected, this information is also displayed and editable in the Project node of the project
tree. Again, clicking on Set PI launches the Investigator Selector dialog, from which the PI can be identified.

Below the Investigators panel, the pdf document to support the science case can be attached. The attachment
is limited to 5 pages and 20 Mbytes. The last panel of the form Observatory use Only contains non-editable
Observatory Information.

Figure 6.4: The lower part of Proposal form with the Investigators and the Science & Technical Case form.

After having filled out the Proposal form, one can start working on the Science Goals.

6.3 Adding Phase-1 Science Goals

A new Phase 1 Science Goal can be added using Edit→ New Phase 1 Science Goal when the Proposal or Planned
Observing node is selected. Subsequently, when selecting the Planned Observing node, the Phase 1 Science Goal
table becomes visible in the Editor pane. The table will initially be empty but it will be filled once Science Goals
are defined. Note that the amount of information that is displayed for a Science Goal can be controlled via the
Appearance tab of File → Preferences.

The number of Science Goals you will have to enter will depend on what exactly it is you are trying to do.
There are currently various restrictions on what it is possible to do with a Science Goal and we list these here.
It is very likely that some if not all of these restrictions will disappear in future releases.

• A Science Goal can only contain observations in a single ALMA band - each additional band will require
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a separate Science Goal.

• All spectral windows must be able to be observed in a single tuning i.e. they must all fit into the receiver
sidebands. Therefore, spectral sweeps must use multiple Science Goals. However, if you wish to observe
the same line species for sources with different redshifts, this is possible so long as the line stays within a
single ALMA band.

• Only one set of Control and Performance parameters can be defined. If you have multiple sources that
require different sensitivities, angular resolutions, etc., they will have to be placed in separate Science
Goals.

• If you wish to observe a source both with a single telescope pointing and a mosaic of multiple pointings,
each must go into a separate Science Goal.

Each Phase 1 science goal contains five forms: General, Field Setup, Spectral Setup, Calibration Setup, and
Control and Performance. These forms are discussed below. An example of a Phase 1 proposal structure with
two science goals is visible in Figure 6.5.

Figure 6.5: Project Structure for a Phase 1 proposal with two Science Goals.

6.3.1 General

A description of the Science Goal can be filled in optionally in the text field in the General form. Text can either
be entered directly into the window or via a sophisticated editor using the Launch Editor button. The name of
the Science Goal can also be set.

6.3.2 Field Setup

In the Field Setup page the user is asked to enter various sources parameters, such as the coordinates and velocity.
The velocity can be specified using the optical, radio or relativistic conventions. Most of the source parameters
can be completed using the Resolve button once the source name has been entered. A window will display the
server name that returned the query results and warn you to check the returned parameters!

The allowed values of the velocity reference frame are: lsr, lsrk, bar, hel, topo. When changing the
source velocity reference system, a dialogue box will become visible with a warning that no velocity conversion
was performed. It is the users responsibility to ensure that the entered information is correct!

The telescope pointing parameters are specified using Target Type. This allows you to define either Multiple
single point fields or 1 rectangular mapping area. Both can be defined in the Forms editor or by using
the Visual Spatial Editor. The default Target Type of each source is Multiple single point fields. To
define a rectangular field, fill in the fields p length, q length, Position Angle and Spacing or use the Visual
Spatial Editor. The Spacing can either be specified in angular units or in fraction of the primary beam; the
default spacing is the Nyquist value (half he diameter of the primary beam). The Position Angle is measured
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in the astronomical sense, positive from the positive x-axis counterclockwise. Once defined, the rectangular area
will be tiled with a mosaic pattern according to the Spacing parameter; this can be viewed in the Visual Spatial
Editor.

Depending on which Target Type has been chosen, the last panel on the page is either Field Centre Coordi-
nates or Rectangular. This lists either the positions of each pointing centre of the parameters of the rectangular
area. Note that coordinates can be provided either as an offset relative to the source coordinates in the Source
panel (fields Offset [RA] and Offset [Dec]), or as absolute coordinate (fields RA and Dec).

Additional sources can be entered using the Add Source button. Note that this can only be done if the
Target Type is set to Multiple single point fields! Therefore, if you wish to define a rectangular mapping
area, you can only enter one source per Science Goal. Delete Source and Delete All Sources do what you
expect. The Field Setup form for a single point field is displayed in Figure 6.6.

A list of sources can be uploaded using Load from File...; this will replace any previously defined sources.
The format of the ASCII source list is displayed in Figure 6.7. For each new source, a new field information form
is created that can be selected using the tabs at the top.

Figure 6.6: The Science Goal Field Setup Form with three sources defined. The selected source has been assigned
a single telescope pointing position.

Figure 6.7: The example of a source list that can be loaded via the Science Goals.

Using an Ephemeris

The Science Goal Field Setup form support the loading of an ephemeris for observing solar system objects. To do
this, select Choose a Solar System Object?; in the drop-down menu that is enabled select Ephemeris. This
will enable an editor that will allow an ephemeris to be added. Note that this ephemeris file must be in the JPL
Horizons format.

In the editor click on Load or View Ephemeris. This will bring up a separate browser. From this browser
click on the button labelled Load HORIZONS file as ephemeris. This will bring up a file dialog. Load the
ephemeris file, and click on Apply Changes. Later one can view or change the ephemeris by the same process.
Also an ephemeris can be saved from the SB to disk. Note that direct editing of the ephemeris field is not
allowed. For details on how to generate JPL HORIZONS ephemeris files please check Appendix C.
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Expected Source Properties (for Technical Assessment)

This panel contains three fields that are used by the ALMA Staff to do a technical review of the Phase 1 proposal.
The only mandatory parameter is the Peak Flux Density. This should be an estimate of either the flux you
expect in a continuum map or the peak flux density of your main spectral line of interest. If you are observing
spectral lines then please enter an expected line width. If your source is polarized, please enter the expected
magnitude of polarization – however, note that polarization observations are not offered for Cycle 0.

6.3.3 Spectral Setup

The Spectral Setup node contains fields to specify the frequencies that you wish to observe. The form consists of
three panels, one to define which kind of spectral setup is required e.g. continuum or spectral line, a second panel
that changes depending on the first choice where you input the spectral information, and a panel for reporting
errors. An illustration of the panel is shown in Figure 6.8. Please note that for Cycle 0 of Early Science,
only bands 3, 6, 7 and 9 are available!

In the upper part of the form the Spectral Type can be chosen. For Cycle 0 of Early Science, the choice is be-
tween Up to 4 spectral elements and Single continuum; More than 4 spectral elements and Spectral
scan are not currently available. For each of the spectral types, the number of polarization products needs to
be selected. The choices are SINGLE_X and DUAL; the default is DUAL as this gives the highest sensitivity. Single
polarization should only be requested if the very highest spectral resolution is desired.

Figure 6.8: Example of a Science Goal Spectral Setup form. Up to 4 spectral elements can be observed.

Up to 4 spectral windows

You can add spectral windows by selecting spectral lines using the ALMA Spectral Line Picker (click on Select
Lines to Observe...). Lines selected using this will automatically be entered into the spectral window table
when the tool is closed. The Spectral Lines Selection tool is discussed in detail in Section 5.6. Alternatively,
click the Add button to define a spectral window and enter the centre frequency (in the rest frame of the source).
Any row can selected by clicking in one of its cells. This will highlight the row and allow you to remove it using
the Delete button.

In the spectral window table the basic spectral settings should be specified:

• Central Freq Rest: The centre frequency of the spectral window in the rest frame of the source.

• Center Freq Sky: This is the observed frequency – it corresponds to the rest frequency and the velocity
of the source.

• Transition: A text string to identify the name of the transition. The field is automatically filled when a
line is selected using the Spectral Line Selection Tool.
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• Bandwidth, Channel Spacing: Double-clicking on this column will bring up a drop-down menu that
displays the available correlator modes; the allowed choices depend on how many polarization products were
selected. The last mode(s) have far fewer channels and are highlighted with a bold font; these are intended
for continuua or low-spectral resolution observations. Please note that channel spacing is not the same as
frequency resolution. The latter (which can be thought of as the observed width of a spectral line with
intrinsic zero width) is a function of the weighting scheme used in the correlator and, for the default choice
of Hanning smoothing, is equal to twice the channel spacing. The choice of smoothing cannot currently
be set at Phase 1. Finally, note that the maximum usable bandwidth is actually 1.8 GHz. Therefore, for
those modes that are wider than this, the edge channels will need to be flagged.

• Process As Continuum: Check this box to indicate if this spectral window is for a continuum measure-
ment.

In choosing your spectral window frequencies, it is important to realise that there are restrictions on where a
spectral window can be located. The fundamental restriction is that all spectral windows must fit into the two
sidebands of the receiver (for bands 3-10). The widths and separations of these vary from receiver to receiver,
but they are graphically illustrated using the Visual Spectral Editor and we recommend that this be used when
defining spectral windows. Also, there is a peculiarity when observing in ALMA bands 3-8: it is currently only
possible to put two spectral windows in each sideband, or all of them in one of the sidebands. Again, this
restriction will eventually disappear. The OT knows about all of these restrictions and will complain if you
define an illegal spectral window setup.

The allowed correlator modes are also subject to restrictions. Not all correlator modes have yet been tested
and so the OT restricts your choice to those that have been made available for Cycle 0 of Early Science. Another
restriction for this cycle is that each spectral window has to have the same bandwidth and channel spacing! This
will also change in future cycles, but for now, if you wish to perform high-resolution/narrow bandwidth spectral
line observations and also require a continuum measurement, this should be defined in a separate Science Goal.

Single Continuum

Setting up a continuum observation is very straightforward as you only have enter the centre (average) frequency
in either the rest-frame of the source or in the observed (sky) frame – you will usually want the latter. With
this information, the OT will then place 4 2-GHz wide spectral windows such that they cover the full 8 GHz
of available bandwidth (per polarization). For bands 3-8 this will result in two spectral windows per sideband
and, therefore, a gap in the frequency coverage. This also means that the requested frequency will not actually
be observed! This is why the fact that this is an average frequency is emphasised. For bands 9 and 10, the
spectral windows are arranged in a single sideband and cover a contigious 8 GHz range. Therefore, the requested
frequency for these bands is observed. We strongly recommend that you view your spectral setup in the Visual
Spectral Editor, to ensure that your continuum bands do not fall in areas of strong atmospheric absorption.

6.3.4 Calibration Setup

In the Calibration Setup form, the user can specify the calibration sources that should be observed. If System-defined
calibration is selected the system will select the calibrators and it is STRONGLY recommended that this be
chosen; the observatory will ensure that suitable calibrators are used.

When a User-defined calibration is specified a five-column table becomes visible in which the calibration
types and the calibration sources can be added or deleted via the corresponding buttons. With user-defined
calibration the user has a choice between Dynamic Calibrators and Fixed Calibrators.

With Add Dynamic Calibrator..., a calibrator query is created using the Calibrator Query Editor. The
user is first prompted for the type of calibration he is trying to create and then defines a search criteria that is
used to search the ALMA Source Catalogue for a suitable calibrator at the time of the observations. The query
can be tested from within the Science Goal using the online version of the current ALMA Calibrator Catalogue
(privileged users can also select a file on disk).
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Alternatively, Add Fixed Calibrator... can be selected. Fixed calibrator sources specify an actual source
to be observed, not a search criteria. They can be a Solar System object, a sidereal source taken from the ALMA
Source Catalogue, or the user can create a source themselves by entering coordinates and, optionally, a flux
measurement. These sources are defined using the Calibration Source Editor, the workings of which are fairly
straightforward.

Figure 6.9: The Calibration Setup Parameters form. The calibration strategy can be selected between System
or User-defined.

Once a calibrator query or source has been defined, it is entered into a table. The parameters of the calibrator
can hereafter be edited using the Edit Criteria... or Edit Target... buttons. The process is exactly the same
as when the calibrators were first defined, apart from the fact that the type of calibrator (phase, bandpass, etc.)
cannot be changed.

6.3.5 Control and Performance

The last part of defining a Science Goal is to specify various performance parameters that effect, predominantly,
the telescope configurations that will be used during the observations and the amount of time that the sources
will be observed for. The latter is displayed if the Time Estimate button is clicked. The ALMA Sensitivity
Calculator can also be selected for experimentation with the requested parameters.

An example of the Control Parameters form is shown in Fig. 6.3.5 with the following fields:

• Representative Frequency: It is used for various calculations within the OT including the field of view
(primary beam size) of the various antenna sizes and the required observing time.

• Antenna Beamsize: Size of the primary beam. Currently only the value for a 12-m antenna is displayed
as the ALMA Compact Array is not yet available.

• Extended Config: Max Baseline and its Beamsize: This gives the maximum angular resolution that
can be obtained during Cycle 0 of Early Science in the extended (400-m baseline) configuration.

• Compact Config: Max Baseline and its Beamsize: This gives the maximum angular resolution that
can be obtained during Cycle 0 of Early Science in the compact (125-m baseline) configuration.

• Desired Angular Resolution: This can be entered in either arcsec or fraction of the primary beam. It
cannot be smaller than the (synthesised) beamsize displayed for the 400-m configuration. We recommend
that you set this to one of the values given for the two Cycle 0 arrays above.

• Largest Angular Scale of source: This specifies the largest angular scale of the source emission that
you wish to map. If your source will not be resolved at the requested angular resolution then click on
Point Source. Otherwise, click on Extended Source and enter the expected value.

• Desired Sensitivity per Pointing: This can be entered in either in Jy or K – the equivalent value in
the other unit will be displayed for information purposes. An equivalent value will not be displayed unless
an angular resolution has been entered. Note that this parameter will be updated if it is changed in the
Sensitivity Calculator.
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• Bandwidth used for Sensitivity: This defines bandwidth that should be used for calculating the required
time based on the sensitivity. There are a number of likely choices in a drop-down menu. Alternatively, a
user-defined value can be entered. This should be chosen if you require less spectral resolution than what
is provided by ALMA in your final spectrum.

• Does your setup need more time?: If you feel that you need more time than suggested by the Time
Estimate button, then select Yes. See below for more information.

• Is this observing time constrained?: If Yes is selected, it is possible to enter a window within which
the source should be observed – a calendar tool is available. A text box is available for entering information
about your time constraints.

• ACA Use: This will eventually be used to test whether the ALMA Compact Array is required to meet
your scientific goals.

Figure 6.10: The Control Parameters form of the Science Goal.

Sensitivity versus Time and Early Science

Please remember that for ALMA observations, you do not request an amount of time, but rather a sensitivity.
This is because it is difficult to predict what sensitivity will be achieved based on an amount of observing time,
mainly due to the fact that mm/submm observations are greatly affected by the weather conditions, as well as
by the usual instances of antenna and other hardware failures. As the sensitivity was presumably chosen by the
user for a good reason, ALMA will observe until the sensitivity is achieved (up to a reasonable maximum limit).
The Time Estimate button on the Control and Performance form will report how long it is expected to take to
achieve the requested sensitivity.

A caveat of this is that for Early Science, the (u, v) coverage will be relatively poor compared to the completed
ALMA array, although still excellent compared to other mm/submm interferometers. However, as ALMA’s very
large instantaneous sensitivity is so good, it is possible that bright sources will have very short estimated times
and this might have consequences for the imaging performance due to the short (u, v) tracks. If this is the case, it
is possible to request a longer amount of time in your Scientific and Technical Case where it should be rigorously
justified. This can be signalled to the proposal review committees by ticking the “More Time” box. As more
antennas are added to ALMA, the need for this should vanish as even the snapshot (u, v) coverage becomes
superb.

Representative Frequency

As described above, the Representative Frequency is used in various calculations within the OT e.g. to plot
the field of views of the individual telescope pointings in the Visual Spatial Editor. Regarding the Control and
Parameters section of the OT, its most important effect is on the estimated time. This is because this frequency
determines the atmospheric opacity that will be used in the sensitivity calculation. If you are observing in a part
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of the spectrum that has very uneven opacity, it is possible that the OT’s choice for this parameter will not be
optimal as no single value can apply to all the spectral windows.

If Up to 4 spectral windows has been selected in the Spectral Setup form, the OT currently sets the
Representative Frequency to the frequency of the first spectral window in the table. Therefore, you should
always try and enter your main line of interest first and add additional lines after this i.e. further down the table.
If Single Continuum has been requested, it simply sets it to that frequency. We strongly recommend that you
view your spectral setup in the Visual Spectral Editor as this will illustrate very clearly whether your spectral
windows lie in a region of strong and uneven atmospheric absorption.

6.4 Summary Information, Validation and Submission

Once you have completed your Science Goals, you can get feedback on the information you entered. If you click
on the top node of a particular Science Goal, it is possible to get a printable summary of that Science Goal from
the Tool menu. If you instead click on the Planned Observing node (which contains all the Science Goals), it
is possible to get a printable summary of them all. In a similar vein, clicking on the Proposal node will give a
printable summary of the proposal and the same on the Project node will give a printable summary of everything
i.e. the proposal and all of the Science Goals. Finally, having clicked on any of the folders, the Tool menu will
give the option of creating a PDF of the entire proposal that will be written to disk. Please note that this
document will be used by the observatory in order to help with the technical assessment of the proposal.

Before submitting the proposal, the proposal should be validated using the icon in the Toolbar. If this is
successful, the submission should proceed without problems. If the validation is not performed by the user
before submission, it will be performed automatically during submission and the proposal rejected if problems
are found. Chapter 11 gives more details about the validation and submission processes.
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Chapter 7

Phase 2 Science Goals

As for creating a Phase 1 proposal, for non-interferometric experts the OT provides an easy way to create Phase 2
observing programs without needing to specify a large amount of observing detail. For standard observations,
the user can create observing projects by defining one or more Science Goals, each of which encompasses one task
the user may wish to perform. Within the Science Goal, the spatial, spectral and a number of control parameters
need to be defined, as well as some information needed for the calibration observations.

Creating a Phase 2 programme via Science Goals is very similar to creating a Phase 1 Proposal and is therefore
only briefly described here; more detailed information is in the previous Chapter 6. For experienced users the
OT also offers the possibility to define a Phase 2 programme in much more detail by constructing Scheduling
Blocks. These details can be found in Chapter 8.

7.1 Basic Information

After having successfully applied for ALMA observing time, the user has to provide detailed technical information
on how the observations are to be executed at the observatory. Only after a successful submission of the Phase 2
information will a programme actually be scheduled on the ALMA Array.

Depending on time allocation policies, the project information in the ALMA Archive may be different from
the Phase 1 proposal that the user originally sent to the observatory, e.g. a project may have been allocated less
time than was applied for or a project may have been split into a number of smaller projects.

Therefore, if you have (an) approved observing project(s), the project information needs to be retrieved from
the ALMA Archive and loaded into the OT. It may also be that the ALMA status (e.g. available configuations)
has changed since the Phase 1 submission. In that case, the information in the OT about ALMA needs to be
updated. For these reasons, it is always convenient and safer to start preparing your Phase 2 programme with
up-to-date information concerning your observing project and the status of the ALMA Observatory.

7.1.1 Loading Project Information

You can retrieve the up-to-date information about your project(s) from the ALMA Archive via File → Open
Project → from ALMA Archive in the menu bar. This will start up the Project Finder dialog box, as displayed
in Figure 7.1, in which you can specify which project shall be retrieved from the ALMA Archive. Clearly, only
those projects can be retrieved for which the user indeed has access permissions. After the specifying the search
criteria a list of project will be displayed and the user can select. The retrieved project will become available to
the OT and you can start working on the Phase 2 specifications of your project.

Apart from retrieving the Phase 1 information from the Archive, Phase 1 and possibly (partially) completed
Phase 2 information can also be loaded from a local .aot file. To load a local file use the File → Open Project
→ From File. . . function from the menu bar.
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Figure 7.1: The Project Finder dialog box for selecting projects in the ALMA Archive.

To download the up-to-date project information from the Archive in the OT and for the actual submission
of Phase 2 programs to the Archive you will need a network connection; all work on a Phase 2 programme can
be done off-line. This is very convenient in case you want to prepare your Phase 2 programme on a laptop while
travelling, for instance.

Independently of how you retrieved the project: make sure that you download up-to-date and correct Phase 1
information before you take your computer off-line and start working on Phase 2.

7.2 Create Science Goals

If you have just started the OT (i.e. without loading a project) the OT displays an empty project structure in
the Project Structure pane. To create a new programme in the menu bar click on File → New Program. You
are now ready to work on the new observing programme and to create one or more Science Goals in the Science
Plan node.

To create a Science Goal, first select the upper project or the Science Plan node. Next, click on Edit → New
Science Goal (star with a “2”). This will create a Science Goal node in the Science Plan folder. It consists of four
forms: Field Setup, Spectral Setup, Control and Performance Parameters and Calibration Setup Parameters, all
identical to the Science Goal fields that have been discussed in Chapter 6 on Phase 1 proposal preparation.

The subsequent steps for filling the the science goals are identical to those described in the previous chapter
for Phase 1.

7.2.1 Science Goal Visual Editors

As with the preparation of the Phase 1 proposal, the Visual Spatial Editor can also be used to specify the field
parameters for the Phase 2 Science Goal. For a description of the Spatial and Spectral Editors, please read
Chapters 9 and 10.

7.3 Generate Scheduling Blocks

As for Phase 1 Science Goals it is possible to generate SBs from the Phase 2 Science Goals: Choose Tool
→ Generate Phase 2 SBs from all the Selected Goal, or use the button Generate SBs from the Selected
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Science Goal in the menu. In the Phase 2 Science Goal the OT will create an ObsUnitSet "xxxx - SI" where
xxxx is the source name. The ObsUnitSet contains the SBs generated from the Science Goal. SB generation
can also be initiated from the right-click pop-up menu, or by pressing the appropriate button on the toolbar. If
the ObsUnitSet and the SBs already exist from a previous mapping, a dialogue box is displayed to check that
overwriting of the previously-generated ObsUnitSet is really desired.

The current version the generation algorithm supports the generation of SB(s) for a single pointing and a
rectangual mapping area. This rectangular mapping area is converted to a multi-field (pointed) mosaic standard
interferometry SB. A single Spectral Setup and Control Parameters is also allowed. For a Science Goal containing
multiple sources, an error/warning message is displayed and SBs for the first source only will be generated.

To see the result of the mapping, you can open the ObsUnitSet node in the Science Goal. From this point you
can manually adjust the SBs. However, again, building and editing SBs requires some experience and in-depth
knowledge of how ALMA works. For further information on how to construct and edit Scheduling Blocks for
Phase 2, consult Chapter 8.

The OT also manages the link between a Science Goal and its ObsUnitSet. For example:

• If a Science Goal has an associated set of SBs, deleting the Science Goal will also delete its ObsUnitSet. A
dialogue box appears asking for confirmation to delete.

• Attempting to delete a generated ObsUnitSet, partially or fully, will result in a warning.

7.3.1 Scheduling Block Restrictions

Presently, SBs generated for Science Goals contain only one source. The number of SBs that are created for a
Science Goal depends on its parameters, mainly the angular resolution and largest angular scale. The algorithm
used to split the project into SBs is described below.

The current version of the Scheduling Block generator does not support sideband separation of DSB receivers,
i.e. using both sidebands, LSB and USB, at a time. The Multi Resolution Mode of the BL correlator is used to
configure more than 1 spectral window in a baseband, each. with potentially a different bandwidth and number
of channels. The Multi Region Mode is similar, but every spectral window must have the same bandwidth and
number of channels.

7.3.2 Algorithm Used for Splitting SBs

The algorithm used to split the requested observation into one ore more SBs considers two requirements: the need
to cover the desired range of angular scales, and the need to ensure full uv-coverage. The ALMA configurations
are designed so that in most cases good uv-coverage is obtained in one go. They generally also provide a wide
range of baselines, meaning only a few configurations are needed to cover most angular ranges desired.

The angular scale range which an array configuration covers is determined by the ratio of the maximum and
minimum baselines of the configuration. Values of this ratio, N , are different among each array configurations;
the value N = 50 is used as a representative value at present.

Let SARG = Smallest Angular Resolution Goal and LARG = Largest Angular Resolution Goal. If N ∗
SARG < LARG, then it is impossible to cover the angular range by a single array configuration. In such a case,
the observation is split into more than one SB. The ideal split would be an SB with a desired resolution goal of
SARG, then one with a goal of N*SARG, and so on.

However, in reality there are other considerations. Here we bring in the following two conditions:

1. We aim for SBs with angular resolution ranges that overlap by 10%. This makes the split SARG, (1-
0.1)*N*SARG, and so on.

2. For scheduling we allow a 50% margin which specifies the range of acceptable angular resolutions. This
makes the split (0.8*SARG, 1.2*SARG), (36*SARGS, 54*SARGS), and so on.
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In terms of hour angle, splitting is only performed when the elevation of the target is low and the resolution
required is sufficiently high that one of the "Y" configurations is needed; this combination will not give good uv-
coverage. The threshold for elevation is 35 degrees and that for resolution is 0.1 arcsec; consequently observations
for which the desired resolution is less than 0.1 arcsec and the elevation lower than 35 degrees are split into two
SBs with 0, 12 and 12, 24 as the minimum and maximum allowed hour angles.

7.4 Phase 2 Validation and Submission

Before submitting the proposal to the ALMA Archive, the validation procedure should be run to make sure that
the Phase 2 programme is technically in a healthy state and consistent with the observatory’s policies. As for
Phase 1, validation is performed on the Scheduling Blocks, specifically those that are created from the Phase 2
program. Details of the validation are described in Chapter 11.2.

After a successful final validation and having saved the work locally, you are now ready to submit your Phase 2
programme to the observatory. The submission process to the ALMA Archive is described in Section 11.3.
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Chapter 8

Phase 2 Scheduling Blocks

This chapter describes how a Phase 2 programme is created by constructing Scheduling Blocks in the OT directly,
i.e. without the intermediate step of creating one or more Science Goals first. As already mentioned in Chapter 7,
by building SBs directly the user has more control over the telescope configuration and observing strategies and
can specify in detail how the instrument will be setup for the execution of a scientific project. It is meant for
experienced users mainly.

Spatial and spectral details can also be provided via the OT Visual Editors. In the following Chapters 9 and
10 the Visual Spatial and Spectral Editors will be discussed.

8.1 Starting Up

To work on the Phase 2 program, in the Project Structure pane select the Phase 2 tab. In the Editors pane
select the Forms tab. Using this tab the forms that need to be filled in will be displayed. The Spectral tab can
be used to provide information via the Visual Spectral Editor (see Chapter 10). The Catalog tab is reserved to
provide details of objects retrieved from catalogue searches.

While creating your Phase 2 programme and entering data in the forms, a validation procedure checks that
the input is indeed legal, i.e. that is has the right format and is within the allowed boundaries. More information
about validation is available in Chapter 11.2.

8.2 Create a Phase 2 Observing Programme Structure

8.2.1 Create a Project

If you have just started the OT (i.e. without having loaded a project) the OT displays an empty project in the
Project Structure pane. To create a completely new project, in the Menu click on File → New Program. If you
have a project loaded in the OT already, a dialog box will appear to ask if the current project can be overwritten.
If you don’t want this to happen you should cancel the action and save your project.

After having started a new project, the Projects Structure pane will contain the beginning of a project with
the Project node as the root which contains a Science Plan folder. Clicking on the Science Plan folder provides
a help message that gives the user basic instructions for creating an observing program. When clicking on the
Project node in the Project Structure tree, the Project form will appear in the Editors pane and can be filled in.

For Staff Only
In the Project form, the panel Advanced Options (Staff Only) contains the field Version for the version of the Project and
buttons for the Project Mode. These can be Manual, Simulation, Calibration, and Commissioning Mode. Calibration
Mode should be checked when it is an Observatory Calibration project. At present this will only make a difference to
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the project code that is generated on submission. There are no other consequences. The CSV team may choose to use
it if they wish. Commisioning Mode should be checked if this is a Commissioning project used by the CSV team. This
indicates to Scheduling that this project is not a normal project and will not follow the normal project lifecycle.

8.2.2 The Observing Unit Set

Next, in the Project Structure tree we have to create an Observing Unit Set (ObsUnitSet). The ObsUnitSets
are nodes that can contain either other ObsUnitSets or one or more SBs. To create an ObsUnitSet, select the
Science Plan folder and choose Add ObsUnitSet either with a right click or from the Edit menu (AddObsUnitSet).
A Special Observing Program folder is created that contains a new empty ObsUnitSet. Note that the Special
Observing Programme is also used/created and populated with Scheduling Blocks when these are generated from
a Phase 1 proposal.

Figure 8.1: The form for the ObsUnitSet. The basic project structure tree is displayed at the left in the Project
Structure pane.

By clicking on the ObsUnitSet node in the Project Structure pane the ObsUnitSet form will appear in the
Editors pane. It is displayed in Figure 8.1 and consists of five panels with fields for entering the following
parameters:

• Basics contains the name, the status of the ObsUnitSet, as well a description;

• Control contains basic control parameters and required accuracies for the ObsUnitSet;

• Unit Dependencies specifies the dependencies between the ObsUnitSets and contains fields for controlling
the execution of the ObsUnitSet;

• ObsUnitSet specifies the scripts for data processing and for controlling the execution of the ObsUnitSet;

• Data Processing defines the desired specifications for the output data after processing the complete Ob-
sUnitSet.
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By selecting the ObsUnitSet node in the project structure tree, a couple of menu items under the Edit button
in the menu will be enabled/disabled. You may also right-click on the ObsUnitSet in the Project Structure tree
to get the drop-down menu. Within the selected ObsUnitSet you have the choice between creating another
ObsUnitSet or a SB; a new SB will be located in the selected ObsUnitSet node. Similarly, when selecting an
ObsUnitSet, this set will be located within the selected ObsUnitSet. By creating multiple ObsUnitSets, each
with one or more SBs, you have the possibility to create a more complex Phase 2 observing program. Note that
an ObsUnitSet can either contain one or more ObsUnitSets or one or more SBs. It cannot contain a mixture of
these.

An ObsUnitSet, either attached to a Science Goal or separately created, can be protected from editing; this
feature is mainly focused on novice users. The default is that it is turned off, but it can enabled by the optional
setting: Menu → Options → Advanced → Enable OUS protect.

Figure 8.2: The lower part of the Scheduling Block form.

8.2.3 The Scheduling Block

Let’s assume the ObsUnitSet now contains a newly-created SB. In the Project Structure pane the SB(s) is (are)
visible directly below the ObsUnitSet. Each SB contains a Target folder with one or more Targets and the folder
Resources, that contains detailed information about the science and calibration Targets, the instrumental setup
and the observing parameters. The Resources folder initially contains 3 empty folder: Field Sources, Instrument
Setup and Observing Parameters.
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When clicking on the SchedBlock node in the Project tree, the SB form will appear in the Editors pane. It
consists of seven panels with input fields. The first three panels, Basics, Control and Unit Dependencies are all
very similar to the panels in the ObsUnitSet form (except that the panels and their fields now apply to this SB).
In case of apparent clashes the SB values will take precedence. The second half of the SB form is displayed in
Figure 8.2.

The last six panels in the SB form are:

• Preconditions which specifies the minimal observing conditions for the execution of this SB.

• SchedBlock which specifies details about how the Scheduling Block is to be executed: maximum time,
number of repeats and the executable observing script.

• Advanced Parameters which is only intended for expert use and is described in more detail in Appendix E.

• Performance Goals and Scheduling Constraints which specifies the science goals for the observations after
data calibration; The panel contains fields for the Representative Target, Coordinates, Frequency, and
Receiver Band. These fields should be filled in case the SB contains more than one Target and/or more
frequency settings (see below) and will normally be completed when a Representative Target is selected
for the SB , either via the SB form in the Editors pane or as a result of SB generation).

• Temporal Constraints where any time constraints for the SB can be defined. Currently not used.

• Observing Groups which displays a table with the Observing Groups in the SB. For further details see
Section 8.3.3.

The SchedBlock panel of the SB form contains a number of fields for describing the observing mode. The
most relevant items in the panel are:

• Standard Mode: A boolean, should be true for indicating a standard mode. For Expert modes the value
should be false and not checked.

• Mode Name: a drop-down list offering the currently available modes: Tower Holography, Astronomical
Holography, Optical Pointing, Offset Optical Pointing, AIV Single Dish, Calibrator Survey, Standard
Interferometry and Expert Mode.

• Mode Type: Observatory (an observatory mode, e.g. calibration), User (science observing) or Expert.

• Obs. Procedure: This file contains the name of the observing script and will be set when filling out Mode
Name; it may also be edited by hand.

• Run Quick Look: This parameter controls whether or not Quick Look is initiated for this SB. At the
moment this needs to be set by the user (default is true). Later, sensible defaults will be applied depending
on the observing mode.

When the SB is generated from the Science Goal (see previous chapter) this information is inserted automat-
ically. However it may be overridden. When the Mode Name and tt Mode Type are set manually the Standard
Mode field should be selected. This will set all of the other relevant information. Eventually, only authorised
observers will be allowed to change the Mode Type, Standard Mode fields and the script.

More SBs can be created when selecting the ObsUnitSet with Edit → Add Scheduling Block. If you are not
happy with your SB you can delete it easily: Click on Edit → Delete. The right mouse button can also be used.

8.2.4 Targets and Resources

As mentioned above, when creating a Scheduling Block, the Target and Resources folder are initially empty. For
a valid Phase 2 program, at least one SB containing at least one Target (science, calibration, optical pointing)
should be specified. Below follow details about the concept of Targets and how these are created. Providing
content to the Targets and Resources folders is described in the next section.
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Targets

A Target essentially defines an observation of a given source that will take place in the timescale of one SB. Its
definition is close to the idea of a scan. Targets are stored in the Target folder which is the first visible when
expanding the SB in the project structure.

The complete observing details of a target are described in the Target form. The form consists of three panels
Field Source, Instrumental Setup and Observing Parameters. The fields in these panels are defined by filling out
the forms in the corresponding folder in the SB Resources folder and attaching these forms to the Target. To be
valid, a Target must have at least one attached Field Source, Instrument Setup and Observing Parameters.

Figure 8.3: An example of the Target and Resources folder in a Scheduling Block.

Working with attachments allows constituent parts of a Target to be re-used, e.g. the same Spectral Setup
may be used in two different Targets, without copying or entering the information twice. Attachments also
provide the ability to specify the scientific intent of a Target and to allow multiple intents for any given Target.
For example, a science Target may also act as a calibration observation (phase, amplitude, etc.).

Normally, a science Target has one parameter set attached to each of the Field Source, Instrument Setup and
Observing Parameters folders.

In the case that a SB contains more than one Target, it is necessary to select one of these to be used as the
Representative target for that SB. This Representative Target is then used to monitor performance goals.

To set a Representative Target, select it in the Target folder in the Project Structure tree and use a right
mouse click to get the popup menu. Select Set As Representative Target. This selection will then fill the
field Representative Target in the SB form. Clearly, only one Target may be selected per SB. Representative
Target can be left empty if the SB contains only one Target.
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Resources: Field Sources

FieldSource forms are contained with the Field Sources folder. Each form defines the details of the source
to be observed e.g. source name and positions, source properties and field pattern that shall be used for the
observations. The latter may be a single point (possibly offset from the source position), multiple points, or
some sort of OTF scan pattern. Presently, rectangular OTF patterns, a list of single points and a cross field
pattern are supported.

Note that for observing objects in the in the solar system an JPL HORIZONS emphemeris can be uploaded.
Details in the Section 6.3.

Only one FieldSource may be attached to a Target.

The Field Source setup in the Schedblock also allows the user to define the source or sources to be used in
the form of a query instead of a specific source. To select this Virtual Targets option check the box at the
top of the editor that says Select target from ALMA Calibrator Catalogue at execution time. In the
Target form in the Editors pane Field Source panel will replace with the Calibrator Search Parameters panel
that provide the various query fields. The panel is identical to the Calibrator Search Parameters panel in the
Calibrator Selection Tool. For details see Section 5.2 and Figure 5.2.

The query is constructed from a cone search over a given radius around a central RA/Dec (J2000) position,
plus min/max frequency, min/max flux limits, and a time window since the calibrators were last observed. This
query is stored in the SB, and at execution time Control will execute the query to retrieve sources matching it
that will be observed. There is also a Maximum number of sources field which instructs control to observe up
to this number of the results returned. Note that since only the ALMA Calibrator catalogue is searched the uses
of this virtual target option are limited, but it is expected to find major use in Observatory Calibration modes.

Resources: Instrument Setup

This folder contains the SpectralSetup form that defines the instrumental setup of the observations e.g. the
spectral specification, the frequency setup and the details for the correlator configuration. Most users will wish
to specify a spectral and correlator setup, but an optical camera setup is also allowed. The latter is used in the
optical pointing calibration mode. A spectral setup basically consists of a receiver and correlator setup.

Only one SpectralSpec may be attached to a Target.

Resources: Observing Parameters

This folder contains the intent for a Target observation and specifies observing parameters, like integration time,
and sensitivity goals. A different name (parameters) was chosen to avoid confusion with the slightly different
use of the word intent in the offline subsystem. There is currently one form for Science Parameters, many forms
to specify the parameters for the various possible calibrations and forms for optical pointing and holography
parameters.

To add observing parameters, first select the folder Observing Parameters in the Resources folder of a Scheduling
Block. Next select the type of observing parameter from the list from the Edit menu or via the right mouse
button. It is possible to attach more than one Observing Parameters to any given Target. Hence, there can be
multiple intentions for a specific Target.

8.3 Targets

After having created a Scheduling Block, the Targets and Resources folders can be populated. This can be
done in any arbitrary order. First create one or more empty Targets and create and fill the FieldSource,
SpectralSetup and Observing Parameters forms. Alternatively, one can first specify FieldSources, SpectralSetups
and ObservingParameters (again in any arbitrary order) and then create a Target in the Target folder. What is
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crucial though is that a Target is only valid when it has an attached FieldSource, a SpectralSetup and one or
more attached Observing Parameters.

Normally, for science observations, the Target folder is populated with at least one observing (science) Target
and one more calibration Targets. In addition to the science and calibration Targets, SBs can also contain
Targets for optical pointing and for holography.

Figure 8.4: A Project Structure that contains one SB. The Target folder contains one science Target and 2
calibration Targets. In the Target folder the calibration Target NRAO530 is selected and its attached forms are
highlighted. The figure shows that the calibration Target is used for pointing and focus calibrations.

8.3.1 Add a Science Target

To add a science Target, first select the SB to which it shall belong or the Target folder. Then from the menu
select Edit → Add Target. Alternatively, the right mouse button can be used after first selecting the SB or the
Target folder. The Target will be added to the Target folder under the SB in the Project Structure tree.

When clicking on the newly-created Target, the Editors pane will display three empty panels i.e. No Field
Source, No Spectral Spec and No Observing Parameters. To have a valid Target, a FieldSource, SpectralSpec
and one or more Observing Parameters must be created and attached. When versions of these exist they can be
used and attached to the newly created Target. The Target form in the Editors pane will provide an overview
of which of these is available.

To create a new FieldSource, SpectralSpec and Observing Parameters, you can use the Create new option.
After creation, the Field Source, Instrument Setup, and Observing Parameters are automatically attached to the
Target. The corresponding panel will then be loaded with empty fields and parameters can be provided. When
specifying the observing parameters, the purpose of the Target needs to ticked first. After all parameters in the
forms have been entered, they are automatically attached to the Target.

More details about entering resources details are given in Section 8.4.
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8.3.2 Add a Calibration Target

Similarly to adding a science Target, a calibration Target can be added to the Target folder via the menu or by
using the right mouse button. Also, creating and attaching a FieldSource and SpectralSpec is similar to what
has been described in the previous section. The choice of the Observing Parameters will depend on the type of
calibration. In the OT, the following calibration types can be specified: phase, pointing, amplitude, polarisation,
focus, atmosphere, delay and bandpass.

Different calibration types may use the same calibrator source. Thus, calibration targets in the Target folder
may share the same FieldSource, but have different SpectralSpecs and Observing Parameters. Similarly, different
calibration Targets may have the same SpectralSpec attached.

To add calibration Targets to an SB that already contains one or more science Targets, the Calibration
Selection Tool can be useful. First select a science Target and then in the OT Menu select Tools → ALMA
Calibration Selection Tool. If the position of the science Target has been specified (in an attached FieldSource)
the Calibrator Selection Tool GUI will display the RA and Dec coordinates. Otherwise, the coordinate fields will
be zero and the user has to provide these. Next, the maximum distance to the science Target shall be defined.
Also, the fields for Frequency and Flux density specification can be filled. With the Calibrator Tag field
the user can optimise the search for a particular calibrator type. Use the Submit Query button to select all
calibration sources that fulfill the specifications. From this list of calibrators, select one by clicking in the table.

After having selected the calibrator, the Select As . . . button provides you with a dialogue box. The dialogue
box consist of two parts. With Calibrator type one can specify for which calibrations the selected calibrator
is to be used (amplitude, phase, etc.). On the right the user can specify which SpectralSpec should be attached
to the calibration Target.

For the selected calibrator, the Calibration Tool will add one Target to the Target folder and attach a
FieldSource and an Observing Parameters set. On the right in the dialog box, Copy to new setup will create
a copy of the science Target’s SpectralSpec and attach this to the calibration Target. Link to same setup
will attach the science SpectralSpec to the calibration Target. Do nothing will not create a SpectralSpec for
the calibration target. Note that a SpectralSpec can only be copied or created when it exists. To create a
SpectralSpec please refer to the next section.

Figure 8.5: Overview of the Targets in the Target folder in the project tree. The table is displayed when clicking
on the folder.

An example of a calibration setup created by the Calibration Tool is displayed in Figure 8.4. In the Project
tree, one science Target has been defined (HD163296). In the Calibration Tool, J1820-254 was selected for doing
phase calibrations. NRAO530 is used for pointing, focus, bandpass and amplitude calibration. For the case
of the bandpass calibration, the Copy to new option was selected to replicate the SpectralSpec of the science
Target and attach it the calibration Target. In the Observing Parameters folder, parameter sets are created for
the different calibration types. By selecting the calibration Target, all forms attached to the calibration Target
are highlighted.

When clicking on the Target folder, the Editor pane shows a table with a summary of the current Targets. For
an example, see Figure 8.5. Similar tables can be displayed for the Instrument Setup and Observing Parameters
folders.

8.3.3 Observing Groups

The user has the ability to create an Observing Group for targets where they can be organised into an ordered
list. Under the SchedBlock node in the Phase 2 programme tree, the user has the option to Add Observing
Groups from the Edit menu or by right clicking on the node and choosing the option from the context menu. A
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new Observing Group folder will appear in the project tree. Clicking on the folder displays the Observing Group
form in the Editors pane.

Figure 8.6: The Observing Group panel in the Editors pane for handing an Observing Group. On the left are all
available Targets. The table on the right lists the Targets in the Observing Group.

At the top of the form the user can enter a name for the Observing Group. The default name for newly
created Observing Group folder is Observing Group N where N is a sequential creation number for that group. The
user can also change the name of the Observing Group by right clicking on the folder in the project tree and
selecting the Rename menu option from the context menu.

The Observing Group panel has two tables. The table on the left includes all of the Targets that have been
created by the user as part of the parent SB. The table on the right shows the Targets that make up the Observing
Group. The user can select Targets from the All Available Targets table and click on the right arrow button to
add it to the Observing Group. Targets in the Observing Group Targets table can be deleted or moved up/down
using the button below the table.

The ordering of the Observing Groups in SB and their names can be edited here. The user can click on
the name columns and edit the observing groups name. Below the table are buttons for manipulating selected
observing group rows in the table. These buttons carry out actions for deleting and moving the rows.

Note that Observing Groups cannot be dragged and dropped in the project tree as this caused unexpeted
behaviour that could be interpreted as a bug.

8.4 Resources

The previous section showed how new targets with (still empty) Field Source, Instrument Setup and Observing
Parameters folders are added to the SBs. Specifying the Resources for the Targets can be done in two ways:

1. Filling out the forms that become visible in the Forms tab of the Editors pane when selecting them in the
Field Source, Instrument Setup and Observing Parameters folders.

2. Using the Visual Editors in the Editor pane. The Spatial tab in the Editors pane gives the Visual Spatial
Editor. Using this editor you can specify the Field Source parameters, including the observing field speci-
fications and the source properties.
The Visual Spectral Editor is available via the Spectral tab and can be used to specify the Instrumental
Setup, e.g. the receiver setup, the position of the lower and upper sidebands and correlator configura-
tions, as well as the frequency specifications for the basebands. The Visual Spectral Editor also offers the
possibility of optimising the receiver frequency settings.

This section deals with entering the Observing Parameters using the Forms editor. After having completed
the Resources forms, Section 8.5 shows how to attach these to a Target.
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8.4.1 Field Sources

To define the Field Source parameters (FieldSource), select on the Field Source folder in Resources. Via Edit →
Add Field Source you can now add a blank FieldSource to the Field Source folder. Alternatively, you can right
click and select Add Field Source from the pop-up menu. Then, when selecting the newly created FieldSource
the empty Field Source form is displayed in the Editors pane.

In the FieldSource form the source properties should be provided. At the top of the form, using the Name
field the name of this parameter set can be specified. Next, you can enter the object name in the Source Name
field. Clicking on the Resolve button may resolve subsequent source parameters in the form automatically (e.g.
the coordinates). A window will display the server name that returned the query results. A tick box is available
for solar system objects with non-sidereal motions. Known flux information of the source can be added into a
table.

Figure 8.7: The upper part of the Field Source form with the Fields Source and Reference Positions panels.
Because the Use Reference box is tagged, the fields in the Reference Position section are made visible.

In the case of single dish observations with on/off source integrations, the user should tick the Use Reference
box. This will expand the Reference Position panel, where the reference position and the on and off integration
times should be given. A second reference tab can be added and deleted using the Add and Delete buttons. For
interferometric observations the Use Reference box should remain unchecked.

The Field Pattern panel can be used to define the area to be mapped and contains a drop down menu for
specifying the actual pointing pattern of the observation, with the source coordinates as the origin of the pattern.
When selecting a pointing pattern the parameters should be provided in the panel below the Field Pattern panel.
An example of this panel in the case of the rectangular pointing pattern is given in Figure 8.8.

Currently, the pointing types point, rectangle and cross are supported. Others will follow. In the case of
single pointing, one can specify the pointing in absolute coordinates or relative to the source position. Hence,
this structure allows you to point in a specific region of your target. Note that the single pointing type allows
one to add more pointings. This is to support arbitrary pointing patterns in case the user does not want to select
the standard pointing field patterns provided.
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Figure 8.8: The lower part of the FieldSource form with the FieldPatternEditor and field pattern properties
(rectangle) panels.

After having created one or more FieldSources and having filled out the forms, clicking on the Field Sources
folder shows a table of the available FieldSources in the Editors pane.

8.4.2 About Basebands, SideBands and Spectral Windows

Upper and Lower Sideband and Basebands

The positions of the upper and lower sidebands (USB and LSB) within the ALMA Receiver Bands are determined
by the choice of the first Local Oscillator (LO1) setting. The bandwidth of each sidebands is 4 GHz for 2SB
receivers (bands 3–8) and 8 GHz for SSB (bands 1 and 2) and DSB (bands 9 and 10) receivers. The central
frequencies of the sidebands are separated from the LO1 frequency by this bandwidth. In order to fully use both
sidebands, the value of LO1 must be separated from the edge of the ALMA receiver band by this bandwidth
×1.5.

For each science or calibration Target, the user can specify up to four basebands. Hence, within the selected
ALMA receiver band it is possible to observe in four basebands simultaneously. The central frequency of each of
these basebands is determined by LO1 and the frequency setting of a second local oscillator (LO2). All basebands
can be placed in either the LSB or the USB or two can be in each sideband. Since the system provides only
limited choices for the LO2 frequencies, obtaining the requested central baseband frequency for each baseband
requires the right combination of LO1 and LO2.

Spectral Windows

The bandwidth of a baseband is fixed at 2 GHz, but data is only taken within one or more spectral windows.These
are defined using the Tunable Filter Bank (TFB), a piece of hardware that allows up to 32 spectral windows to
be placed within each baseband. Each spectral window is built up from filters that have a bandwidth of 31.25
or 62.5 kHz, the smaller value only being available when Twice Nyquist sampling i.e. oversampling, is utilised.
In this way, one or more spectral windows with a variety of bandwidths can be placed independently in each
baseband. The rules for doing so are complicated, but the OT tries to guide you through the restrictions. Up
to 8192 spectral channels can be placed across the spectral windows in each baseband, depending on various
things, but including the number of polarisation products that are being calculated. This number also depends
on the number of correlation bits and on whether the data are being oversampled. The maximum bandwidth
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of a spectral window cannot be greater than the baseband bandwidth and the choices for the resolution are
restricted. The ALMA correlator is therefore extremely flexible and can be configured in a large number of ways.
For example, a 1-GHz wide spectral window with 4096 channels can be combined with one with a 125-MHz
bandwidth, also with 4096 channels, but delivering much higher spectral resolution. The central frequency of
each can be set independently.

In order to determine the continuum level in a spectral window, a maximum of ten spectral average regions
can be specified. For each of these spectral average regions, a start channel number and the number of channels
over which the average is to be calculated should be specified.

The spectral specification is defined in the SpectralSpec form in the Instrument Setup folder in the Resources
folder of the SBs. Below, an overview of the various panels in the SpectralSpec is given.

8.4.3 Instrument Setup

In order to successfully specify the various parameters for the frequency, baseband and correlator settings, this
section gives an overview of the possible choices and their mutual dependencies. Note that not all input fields
of the SpectralSetup form are discussed. A complete list of all Instrument Setup parameters and their detailed
descriptions is provided in the ALMA OT Reference Manual.

Three choices for the Instrument Setup

With ALMA, a signal can be detected using one of two correlators or with the square-law detector. For a
correlator setup one can choose between the bi-lateral/baseline (BL) correlator and the Atacama Compact
Array (ACA) correlator. Note however, that within a single SB only one type of correlator can be selected.
Hence, once a setup with one type of correlator is added, you are prevented from choosing the other type when
adding to that SB.

In the SpectralSpec form, the parameters needed to define a spectral specification and the correlator or the
square law detector setup should be filled in. To create the SpectralSpec form select the Instrumental Setup folder
in the Resources folder. Via Edit → Add Spectral Spec with BL Corr Config, Edit → Add Spectral Spec with ACA
or Edit → Add Spectral Spec with Square law detector you can add one of the two correlator configurations or
the square law detector. Alternatively, you can right click and select Add ... from the pop-up menu.

If you wish to use square law detectors together with BL or ACA correlators, i.e. to set up a hybrid mode
observation, add a spectral spec with BL correlator configurations (or ACA) and then check the Total power
with square law detectors check box in the Spectral Spec panel in the SpectralSpec form editor.

When selecting the newly-created SpectralSpec, the empty spectral specification form is displayed in the
Editors pane. First, select either the Forms or the Spectral tab of the Editor pane and make sure to extend
the Editors pane or to scroll so that the Spectral Spec and either Correlator Configuration or Square law Setup
panels of the SpectralSpec form are completely visible as displayed in Figure 8.9. If the Spectral tab is selected,
the Visual Spectral Editor is enabled (see Chapter 10).

SpectralSpec

At the top of the form, the name of the Spectral Spec set can be entered, followed by the rest frequency of the
line and its transition (e.g. for a known molecular line). The button Line Catalogue can be used to launch the
Spectral Line Selection Tool. A detailed description of the tool can be found in Section 5.6.

If you select the line from the catalogue list the fields are filled in automatically. The Receiver Band field
is defaulted to the correct value. Alternatively, you can specify the Transition and Rest Frequency fields
manually. Also, even with manual input, the Receiver Band will be defaulted based on the frequency.
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Figure 8.9: The panels and fields for the Spectral Spec, Switching and Correlation Configuration. A similar
layout exists for the the square-law detector.

Switching

Below the SpectralSpec panel is the Switching panel. The default setting for switching type is NO_SWITCHING
and the fields for other parameters Dwell Time and Dead Time in this panel are disabled. Those fields will
be enabled by selecting one of the switching types other than NO_SWITCHING or FREQUENCY_SWITCHING. If you
choose FREQUENCY_SWITCHING, you can set up switching configuration at the Switching panel in the Baseband
configuration editor below.

Square Law Setup

This panel is only visible when the Square Law Detectors option is selected, either in the Square Law Detector
SpectralSpec form (created with the Add Spectral Spec with Square Law Detector option) or when the Add
Total power with square law detectors... box is checked in the BL or ACA SpectralSpec form. Note that
in the latter hybrid case, the same basebands are used for the correlator and square law detector.

Correlator Configuration

This panel is only visible on the BL and ACA Instrument Setup form, i.e. when the Baseline correlator or the
Atacama Compact Array correlator has been chosen.

The BL correlator configuration validator has four options for BL correlator restrictions: 4 quadrants, 2
quadrants, 1 quadrant and 2 antennas. The default is 4 quadrant i.e. the full ALMA correlator. You can change
this in Select BL Correlator Type section of the Preferences → Telescope menu. As the choice is saved in the
user preference file, you don’t need to do so every time. The 2-antenna option was mainly used for the ALMA
Test Facility two-antenna interferometer and is unlikely to be needed.

In the panel Correlator Configuration, the fields Integration Duration and Channel Average Duration
are visible. Integration Duration determines the number of Dump Durations that can be specified in the
special field (16 ms for cross correlations, and 1, 2, 4, 8, or 16 ms for auto-correlations) to be executed before
sending data off for the spectral windows to be accumulated. The Integration Duration will be longer than
the Channel Average Duration (see below) and is often a multiple of it, but it doesn’t need to be. Further the
Atmospheric Phase Correction Data To Save option can be chosen. To help the user to get these numbers
right, the ADJUST buttons can be used.

Also visible in the Correlator Configuration panel are the drop down lists to select thr Correlator Accumulation
and Local Oscillator modes and the check boxes to select the 90 or 180 degrees Walsh function to be applied.
Please check the Reference Manual for further details.
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Below the Correlator Configuration panel, the BaseBand Configurations specifications can be filled in. The
following paragraph describes how this is done.

BaseBand Configurations

In the panel BaseBand Configurations up to four baseband configurations can be defined. An overview of the
upper part of this panel is provided in Figure 8.10. A number of fields for specifying the basebands and their
spectral windows are described below. More details can obtained in the OT Reference Manual.

This panel contains a summary table of the baseband configurations; it lists the name, center rest frequency,
data products and sideband separation, the LO2 frequency and the data rate for each of the basebands. Just
above this is the LO Setup Preferences panel that can be used to calculate the LO frequencies. Depending
on how many baseband configurations have been defined, the LO Setup Preferences subpanel can be used for
optimising the position of the frequency band by adjusting the LO1 and LO2 settings. In the Sideband(s) to
priotise check boxes the user can indicate the priority for the USB and LSB. Below there are check boxes for
each of the base bands in which the user can enter a weight between 0 and 100 to priorities these base bands for
calculating the LO1 frequency. Pressing the Calculate LOs button will calculate the LO setup according to the
entered parameters.

The best setup, in terms of LO1 (and LO2) settings for a single or multiple baseband configuration is
determined by calculating the error between the ideal and the adjusted LO2 settings for each of the basebands and
minimising the sum of these errors. After clicking on the Calculate LOs button, a summary of the optimisation
results can be seen in the pane, using the Information tab. Clicking on the expansion symbol >> will provide
you with the details, including the ideal setting of the LO1 and LO2 frequencies, the frequency offsets given
the system limitations in setting the LO2 frequencies and the adjusted LO1 and LO2 frequencies. After the
optimisation is done, the results are visible in the LO1 Frequency fields. Also visible is the expected total data
rate.

Figure 8.10: The fields for defining the baseband Configurations.

LO Configuration is also supported by the LO Configuration Tool via Tools → ALMA LO Configuration
Tool. This is an experimental tool that runs on a separate window and is also intended for expert users. It
implements the same algorithm which will be used in the Control subsystem that will set the LO settings during
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the actual observations. For details see Section 5.3.

In the BaseBand Configurations panel there is also an advanced Engineering sub panel. The user must click
on the Engineering Set-up button to enable this sub panel. After doing so the user can enter values for the
FLOOG, enable/disable Tune High and the LO1 Frequency value directly. Enabling the engineering set-up also
has the effect of making the Center Freq (Rest) column read-only and the LO2 Frequency writable in the base
band table.

Baseband Specifications

Below the baseband summary table and the LO Setup Preferences panels are tabs containing the details of each
of the basebands. Initially, no baseband configuration is available and at least one baseband configuration should
be defined. To create a baseband configuration, hit the Add BaseBand button. The first baseband (with index
1) will become visible. Most fields will be zero or have default values.

As already mentioned, some of these parameters depend on previous settings, e.g. on the receiver bands and
on other settings in the upper panels of the form.

In the Products & Sideband Separation field you can specify the combination of correlation products and
the sideband separation mode. Only allowed combinations are listed, this depending on the receiver type and
the choice of Accumulation Mode. When ALMA_FAST is selected for the accumulation mode, AUTO_ONLY & NONE
is the only choice. Otherwise, i.e. when ALMA_NORMAL is selected, one or more choices are listed depending on
the receiver type. FREQUENCY_OFFSET_REJECTION is the only allowed choice if the receiver type is SSB (Band 1
and 2) or 2SB (Band 3-8). Note that PHASE_SWITCHING_REJECTION is not listed: it is not supposed to be used
although ALMA has the function. For the DSB (Band 9 and 10) receiver type, the modes of separation are
PHASE_SWITCHING_SEPARATION and FREQUENCY_OFFSET_SEPARATION as well as FREQUENCY_OFFSET_REJECTION.
The option FREQUENCY_OFFSET_SEPARATION is not available for the ACA correlator.

Spectral Windows

After a configuration is created for each of the basebands, one or more spectral windows need to be specified. At
the moment, up to 32 spectral windows are supported. Each of these windows will correspond to a contiguous
spectral region within the baseband bandpass. The bandwidth of a spectral window can range from 31.25 MHz
to 2 GHz and they can be observed at a spectral resolution that also depends on the number of spectral windows
that are being used and their specifications. A maximum of 8192 channels per baseband is allowed, depending
on the polarisation mode. The validator will actually check if specifications do not exceed the available resources
of the correlator.

For each of the baseband configurations the details of the spectral windows are included in the Baseband tab
in the Spectral Windows panel. At the top a summary table provides an overview of the spectral windows that
are defined for the baseband. Some of the spectral window parameters can be specified in the table by clicking
in the table cells. Below the overview table, for each spectral window the full set of parameters can be displayed
by selecting the spectral window’s tab. A few input parameters are commented on below.

Clicking the Add button below the summary table, a SpectralWindow or a pair of SpectralWindows is added
depending on the receiver type and the choice of Products & Sideband Separation value. Key parameters of
all spectral windows defined in the baseband are displayed in the table. Details about some of these parameters
are described below.

The value of the center frequency is constrained to multiples of approximately 32 kHz for the BL correlator
and 4 kHz for the ACA correlator. The value typed into the table is adjusted automatically, while you need
to click the Adjust button in the tab. In the spectral window table the colour of the offset turns red if the
spectral window does not lie within the baseband. The field use USB and use LSB cannot be changed for single
sideband (bands 1 and 2) or two sideband (bands 3–8) receivers, as the sideband is chosen by the OT according
to the center and LO1 frequency. For a double sideband receiver (bands 9 and 10), sideband selection depends
on the choice of Products & Sideband. For the AUTO_ONLY & NONE case, both LSB and USB are selected. This
is due to the restriction that the signal of both sidebands cannot be separated for auto correlation mode. For
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Figure 8.11: The fields for defining the spectral windows.

the CROSS_AND_AUTO & FREQUENCY_OFFSET_REJECTION case, either use LSB or use USB is selected according
to the center frequency of the baseband and LO1 frequency, and the selection is not allowed to change. For
the CROSS_AND_AUTO & FREQUENCY_OFFSET_SEPARATION or CROSS_AND_AUTO & PHASE_SWITCHING_SEPARATION
case, two spectral windows are defined at a time as a pair, one in the LSB and the other in the USB. You
can remove the check for either sideband you don’t need. All the spectral window parameters except a few
are common to the spectral windows defined as a pair and the parameters for the both sidebands are displayed
and editable on a tab. Note that FREQUENCY_OFFSET_SEPARATION does not appear in the Product & Sideband
Separation list box for an ACA spectral spec because the ACA correlator does not support this function.

There are restrictions between the nominal bandwidth and the nominal number of channels of the spectral
window for the BL correlator. You will see 3 types of representation in the list box for those parameters: black
characters, grey characters, and grey characters with a stroke.

Black characters are used to indicate that the value is valid against the setting of the other. When you see
the list box for nominal bandwidth, choices in black are valid against the current value of number of channels,
and vice versa. Choices in gray with or without stroke are invalid. Stroke means the value is available against
none of the choices of the other. In other words, the value is not available for the settings of other parameters:
polarization, correlation bits, oversampling, and quantization correction. Choices in grey without stroke will be
valid and turn black when one of the valid choices is chosen for the other.

For every Spectral Window at least one Spectral Average Region needs to be set. For the case that spectral
windows are defined as pairs, i.e. sideband separation is selected for a DSB receiver, a check box labeled
Creates the same region in the mirrored window is displayed below the Spectral Average Region table.
As the default this is checked and the regions displayed in the table are applied to the both sidebands. Remove
the check if you want to set different spectral average regions to LSB and USB, then you will see columns labeled
LSB and USB which allows you to select which sideband or both use the region.

After having created and filled out one or more Instrument Setup forms, clicking on the Resources/Instrument
Setup folder shows a table with the available Instrument Setups.

8.4.4 Observing Parameters

For each target type (science, calibration, optical pointing) the user must specify Observing Parameters. To
create an Observing Parameters set, select the Observing Parameters folder in Resources. Via the Edit menu you
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can now select the type of observing parameters you want to add to the Observing Parameters folder. There is
one for adding science parameters, one for the various calibrations as well as for optical pointing, holography
and radiometric pointing. Alternatively, you can right-click and select one of the observing parameters options
from the pop-up menu.

Figure 8.12: The form for the Observing Parameters. The tabs for science and calibration targets and for the
special Observatory Setups are visible. The tabs become visible when the corresponding entry in the Observing
Parameters folder in the Project Tree is selected.

When selecting the newly-created entry in the Resources/Observing Parameters folder, in the Editors pane
the empty observing parameters form is displayed. For each of the possible observing parameters sets there is a
separate tab. When selecting an Observing Parameters folder the corresponding tab in the Observing Parameters
form is enabled as displayed in Fig 8.12. The Science Observing Parameters form includes the name of the
parameter set, the representative frequency and bandwidth and the sensitivity goal for that frequency and
bandwidth. For calibration observations, most of the observing parameters include the name of the parameter
set, the cycle time (how often the calibration shall be repeated) and the default integration time. An exception
is the observing parameters for pointing calibrations. This parameter set also contains the desired accuracy and
which pointing method shall be used.

Note that the tabs for science and calibration parameters contain a sub panel Advanced Parameters which is
only intended for Expert use and is described in more detail in Appendix E. After having created one or more
ObservingParameters data sets, clicking on the Resources/Observing Parameters folder shows a table with the
available observing parameters sets.
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8.5 Attaching Resources to Targets

8.5.1 Attaching New or Existing Resources

To attach a resource to the Target, select the Target in the Target folder. Then in the menu bar select Edit
→ Attach/Detach ..., or use the right mouse button. A dialog window will be displayed showing the Field
Sources, Instrument Setups and Observing Parameters that are available in the Resources folder. From the
column Attachable Components the resource can be selected and added to Selected column using the right arrow
button. Detaching resources from a target goes in the opposite direction.

Figure 8.13: A Phase 2 observing programme structure that contains one Scheduling Block. The Scheduling
Block contains 5 Targets. FieldSource, SpectralSpec and Observing Parameters forms have been created in
the Resources folders. The figure shows the highlighted target HD163296 in the Target folder and the attached
parameter sets.

Attaching resources can also be done at the time a new Target is created. When clicking on the new Target,
the Field Source, Spectral Spec, and the Observing Parameters panels contains a listing of the available resources
that can be selected for the Target. Alternatively, the user can also choose to create and attach a new resource.
In that case a new resource will be created in the corresponding Resources folder and attached to the Target.

After having attached a Field Source, Instrument Setup and one or more Observing Parameters, the Target
information is complete. Clicking on the Target will show the complete Target form in the Editors pane and
highlights the parameters sets in the Resources folder that are attached to the selected Target. Similarly, by
clicking on a resource, the Target to which this resource is attached will be highlighted. An example of this is
visible in Figure 8.13.

When selecting a Target, the form in the Editors pane displays the content of the attached FieldSource,
SpectralSpec and Observing Parameters. At the top of each of the FieldSource, SpectralSpec and Observing
Parameters forms, a line is displayed that gives the number of targets that use that parameter set. When it is
used by more than one Target, a warning icon and the Edit Only This button appears along with the information.
Editing a parameter set affects all the Targets to which it is attached. To only edit the parameter set for the
Target which is displayed, click the Edit Only This button. This duplicates the parameter set and attaches it
only to the Target which is being edited.

When selecting a FieldSource, SpectralSpec or Observing Parameters in the Resources folder, the form in the
Editors pane provides information on how many targets are using it.
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8.6 Submit the Project

After having completed the Phase 2 observing programme, ObsUnitSet, SB and Target forms, the validation
procedure should be run to make sure that the programme is technically correct and compliant with the Ob-
servatory policies. Also, the validation can check that the anticipated total observing time does not exceed the
Phase 1 allocations and that the data rates are within the limits.

Finally, after successful validation, the Phase 2 programme can be submitted to the ALMA Observatory
Archive where it will be checked further and eventually executed.

Detailed information about Project validation and submission can be found in Chapter 11.2.
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Chapter 9

The Visual Spatial Editor

The Visual Spatial Editor can be used for entering position information into a Phase 1 or Phase 2 Science Goal,
as well as a Phase 2 Scheduling Block.

The Spatial Editor becomes visible via the Spatial tab in the Editors pane by either selecting:

• The top node of a Science Goal (Phase 1 and Phase 2).

• The Field Source node within a Science Goal.

• A Target within a Scheduling Block.

• A Field Source within a Scheduling Block.

The main difference between the SB and Science Goal versions of the Visual Spatial Editor is the display of
the telescope pointing parameter fields located to the right of the image display i.e. the information that would
be shown if the Forms editor tab was selected. The interface to the image display is identical for both a Science
Goal and an SB.

9.1 Overview of the Graphical Interface

The Visual Spatial Editor interface consists of two main areas. On the left is the image display. In addition to
the main window, the image display contains two smaller sized windows. The top one displays the whole image.
When the image is zoomed in the main display, a yellow square marks the area of the image that is visible. Using
the left cursor button you can position the yellow square and the area of the image that is displayed. The other
small window contains the zoomed part of the image centered on the actual position of the cursor in the main
window.

Above the image display there is a toolbar that can be used for loading and saving images, for manipulating
source and telescope pointing positions and for setting the intensity cut level in the display. Their use is described
in the following section. Below the image display there are buttons for zooming in and out, as well as fields
showing the position of the cursor, in image and sky coordinates and the pixel value at that position. The lower
line gives the name of the image file that is loaded and its location. An example of the image display can be
seen in Figure 9.1.

Below the image display and its menu and control buttons the panels Fov Parameters and Image Query panels
are visible. In the upper Fov Parameters panel the user can input the frequency and the antenna diameter that
shall be used for calculation of the Field of View (FOV, primary beam). In the panel Image Query the image
server and the size of the retrieved image can be specified. The query button will retrieve the selected object
from the image server and load the image in the display window. The fields in the Image Query panel are used
for specifying the image server and the size of the image to be displayed. These panels are shown in Figure 9.2.
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Figure 9.1: An example of the image display area on the Science Goal Visual Spatial Editor. The source position
(big cross) is marked.

The right side of the Spatial Editor shows a form that is divided into a number of panels that contain the
parameters for either the Science Goal Field Setup node, described in Section 6.3.2, or the SB Field Source node
described in Section 8.4.1. Below follows a brief summary of what is visible. Please refer to these sections for
detailed information.

9.1.1 Science Goal Information

In a Science Goal, the right-hand side of the OT shows information about the source definition that can otherwise
be seen in the Forms editor view by clicking on the Field Setup tab (next to the Spatial tab). Note that all
parameter changes that are made in the Visual Spatial Editor will be reflected in the forms editor (Field Setup
tab). The right-hand side of the Visual Spatial Editor is displayed in Figure 9.3.

9.1.2 Scheduling Block Information

In an SB, the right-hand side of the Visual Spatial Editor shows information about the source definition that
can otherwise be seen in the Forms editor view by clicking on the tab next to the Spatial tab that has the name
of the source. Note that all parameter changes that are made in the Visual Spatial Editor will be reflected in
the forms editor.
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Figure 9.2: The FOV Parameters and the Image Query panels in the Visual Spatial Editor.

9.2 The Tool Bar and Zoom Functions

A local image can be loaded in the image display. To load the image, click on the left button on top of the
image display. A dialog box will be displayed to select the image to be loaded. Note that only images in FITS
format can be loaded in the image display. Also note, that the source coordinates in the form at the right are
not changed when a local image is loaded. A dialog lets the user know if the coordinates of the loaded image are
inconsistent with the source coordinates.

Loaded images can be saved locally using the Save button on top of the image display. Clicking on the Save
button will display a dialog box in which one can select the location and the name of the saved image. Images
will be saved in FITS format.

To specify and mark the location of the source coordinates, click on the big cross in the tool bar of the image
display. Next click in the image display at the position that shall be the source center. A cross will now mark
the chosen position. Using the left mouse button you can drag the cross, i.e. adjust the source coordinates to
another location. The source coordinates are filled in the Source Coordinates field in the Source (Science Goal)
or Field Source Editor (SB) panel at the right. The update also works in the opposite direction: editing the
Source Coordinate field will move the cross to the new position in the image display.

A coordinate grid in RA and Dec can be overlayed on the displayed image. To show the grid, just click the
button with the tooltip Show/Hide Grid on top of the image display area when an image is displayed. This is
a toggle button and the grid will be hidden by another click. The number of lines in the grid is automatically
determined.

The zoom factor of the image can be set using the magnifying glass button below the image display. Note,
that when the image is zoomed in the main display, a yellow square marks the area of the image that is visible
in the upper smaller window. Using the left cursor button you can position the yellow square and the area of
the image that is displayed in the main window.

9.3 Loading External Images

Loading of images in the display can also be done by providing input to a few fields at the right. First enter the
object name in the Source Name field and click on the Resolve button. A window will display the server name
that returned the query results. A drop-down menu is available to select the coordinate system and a tick box
for selecting sexagesimal notation.

Assuming you have a network connection, to load the object in the image display, first select from which
image server the image shall be retrieved and an image size – larger sized images will load more slowly than
smaller ones. Clicking on Query will download and display the image. Note that coordinates are used in the
query if both the name and the coordinates are specified. Also, it is possible to display a field having specified
the Source Name or Source Coordinates fields only.
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Figure 9.3: The right side of the Science Goal Visual Spatial Editor. This information is also shown using the
forms editor.

9.4 Telescope Pointing Patterns

ALMA supports a number of telescope pointing types or field patterns. These pointings are specified in the Field
Setup section of a Science Goal, the Field Source section of an SB or in the corresponding panel of the Spatial
Editor of either.

In a Science Goal, the telescope pointing pattern is specified by selecting either Multiple single point
fields or 1 rectangular field from the Target Type field. In an SB, the pointing positions can be chosen
from a number of field patterns, including also including single point and rectangular fields. Whether you are
editing a Science Goal or an SB, if the pointing position is relative to the source position, moving the source
position in the image display will also change the pointing position.

The subsections below describe how to define the field center coordinates of the pointings both for the single
point and rectangular field options.

9.4.1 Target Types for Science Goals

The pointing option can be selected via the Target Type radio button in the Target panel right of the display.
By default the Multiple single point fields option is set. As mentioned before, the fields are identical to
those in the Science Goal field.

Multiple Single Point Fields

For the Multiple single point fields target type, the user can define one or more sources. For each source
field and pointing parameters a new tab is created in the Source panel. Adding more fields is done via the Add
Source button at the bottom of the page.

For each source, multiple pointing centres can be specified by clicking the Add button in the Field Center
Coordinates panel. The positions of the pointings can be entered into this panel in either absolute or relative (to
the source position) coordinates.
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Alternatively, pointings can be added using the FOV icon in the toolbar above the image display – clicking
in the image display will create the new pointing and a circle and a plus marker will become visible. The plus
indicates the pointing position; the size of the circle represents the FOV. To adjust a pointing position select the
pointing position using the left mouse button. The pointing marker in the image display will turn grey and can
be dragged.

As mentioned above, these parameters are identical to those in the Field Setup form. For relative as well
absolute field centre coordinates, when moving the pointing position in the image display the corresponding fields
values in the form will also change. In the case of relative pointing coordinates, when moving the source position
in the image display the pointing position will also change.

In order to calculate the FOV the frequency and the antenna diameter need to be specified. This can be
done in the FOV Parameters panel below the image display. To tell the Visual Spatial Editor which frequency
is to be used, one needs to specify a frequency in the Frequency used field. In case the frequency has already
been defined, the Refresh button can be used. When this button is clicked, the OT gets the frequency from the
Spectral Setup form.

Rectangular Field

For the rectangular field target type only one source can be specified. This option is enabled by selecting
1 rectangular field which will then create a panel called Rectangle within which the fields to specify the
parameters for the rectangle can be specified. The parameters of the rectangle include the relative or absolute
position, its length, width and position angle.

The rectangle parameters can also be specified via the rectangular shape icon on top of the image display
window. When clicking this button the cursor can be used to create a rectangle and to determine the position,
size and position angle – the rectangle can be resized by the blue handles and can be rotated by the green
handle. The parameters of the rectangle also fill the fields in the form at the right. Spacing is the angular
distance between the positions of the individual pointing, specified either in angular units or in fraction of the
synthesized beam. The default is to use half of the antenna beamsize (field of view) which is equivalent to
Nyquist sampling.

Clicking the Show pointing positions button if a rectangular area has been defined will cause pointing
positions to be displayed. Be sure that the Spacing parameter is set or else nothing will happen. The display
can be toggled on and off with this button. The figures presenting the positions are not selectable, but they are
updated following the actions of move, resize and rotate to the rectangle. To hide the circles representing the
field of view, uncheck Show FOV(circle) in the FOV Parameters panel below the image.

9.4.2 Field Patterns for Scheduling Blocks

The pointing options are available via the drop down menu in the FieldPatternEditor panel at the right. Note
that not all the listed options are implemented. The fields are identical to those in the SB Field Source form.

Point

For each source, multiple pointing centres can be specified by clicking the Add button in the Point panel below
the FieldPatternEditor panel. The positions of the pointings can be entered into this panel in either absolute or
relative (to the source position) coordinates.

Alternatively, pointings can be added using the FOV icon in the toolbar above the image display – clicking
in the image display will create the new pointing and a circle and a plus marker will become visible. The plus
indicates the pointing position; the size of the circle represents the FOV. To adjust a pointing position select the
pointing position using the left mouse button. The pointing marker in the image display will turn grey and can
be dragged.

As mentioned above, these parameters are identical to those in the corresponding form editor (chosen using
the tab next to the Spatial tab). For relative as well absolute field centre coordinates, when moving the pointing
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position in the image display the corresponding fields values in the form will also change. In the case of relative
pointing coordinates, when moving the source position in the image display the pointing position will also change.

In order to calculate the FOV the frequency and the antenna diameter need to be specified. This can be
done in the FOV Parameters panel below the image display. To tell the Visual Spatial Editor which frequency is
to be used, one needs to specify a frequency in the Frequency used field. In case a frequency has already been
defined, in either an Instrument Setup or Observing Parameters definition, the Refresh button can be used.

Rectangle

The parameters of the rectangle include the relative or absolute position, its length, width and position angle.
They can be specified via the rectangular shape icon on top of the image display window. When clicking this
button the cursor can be used to create a rectangle and to determine the position, size and position angle – the
rectangle can be resized by the blue handles and can be rotated by the green handle. The parameters of the
rectangle also fill the fields in the form at the right (in the Rectangle panel) and can also be specified here. Note
that the contents of this panel are somewhat different to those given in the Rectangle panel of a Science Goal.
This is because the rectangle definition within an SB can also be used to perform a raster scan and not just
to set up a mosaic. The additional parameters are Orthogonal Step, Scan Direction, Unidirectional Scan,
Scan Velocity, and Scanning Coordinate System.

Figure 9.4: Example of a mosaic definition based on a rectangular pattern in an SB.

The rectangular field pattern can be converted to a mosaic of pointings. Click on the Setup Mosaic button
in the Rectangle panel – this displays a new panel called Mosaic Parameters. The frequency is taken from the
FOV Parameters panel below the image display and, as with there, is used to calculate the antenna beamsize
(primary beam) depending on the choice of antenna, 12 m (ALMA) or 7 m (ACA). The default value of the
spacing (Overlap) is set to the Nyquist value of 50% of the antenna beamsize. Once the mosaic pattern has been
chosen (Layout Type), the mosaic can be created using the Convert to Mosaic button. A series of telescope
pointings with associated FOVs will be displayed on the editor filling the rectangle. An example of a mosaic
specification is given in Figure 9.4.
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Other Field Patterns

In addition to Point and Rectangle, the OT also supports the Cross field pattern. Spiral and Circle are not
currently supported.

9.5 Visual Spatial Editor Useful Features

The Visual Spatial Editor provides the following useful features, some of which have not been mentioned until
now:

• With the Image Cut Levels button (second right button above the display window) the intensity scaling of
the displayed image can be changed.

• Changes made in the pointing table will also cause an update of the pointing markers in the image display.

• Vice versa, pointing changes made in the image display (e.g. dragging one or more pointing positions) will
also update the pointing table.

• When a row is selected in the pointing pattern table, the corresponding FOV marker in the image display
is selected.

• The coordinates for the pointing pattern can be in either absolute or relative (to the source) coordinates.

• If offset coordinates have been selected, a change of the source coordinates field causes all the FOVs on
the image to move. When absolute coordinates are selected, the positions of the FOVs do not change even
though the source coordinates change.

• The FieldSourceEditor panel informs the user how many Targets are using the FieldSource. When the
FieldSource is used by more than one target a warning icon will be displayed. Editing the FieldSpec
parameters will affect all Targets that have this FieldSource attached. When a Target is selected and
the FieldSource is used by more than one target, the Edit Only This button appears along with the
information. To only edit the FieldSource parameters for the target which is displayed, click this. This
duplicates the parameter set and attaches the FieldSource only to the target which is edited.

• With the middle cursor button, distances in the image display can be measured.
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Chapter 10

The Visual Spectral Editor

The purpose of the Visual Spectral Editor is, apart from the graphical presentation of the various parameter
settings, to offer the possibility of adjusting and optimising various frequency setting parameters interactively
using the cursor.

The Visual Spectral Editor comes in two flavours: a simple version for filling out the spectral setup for
Phase 1 and Phase 2 Science Goals and showing information about the selected receiver band, the rest-frame
and observed frequencies and the atmospheric transmission curve. A far more elaborate version is available for
completing the SpectralSpec of a SB Instrument Setup and shows more baseband details and the settings of the
spectral windows.

Together with the graphical information, the Visual Spectral Editor also shows some of the fields in the
corresponding form editor of the Science Goal or SB. These fields have already been discussed in the discussed
in the corresponding sections. The details for the Science Goal spectral setup can be found in Section 6.3.3. The
details for the complete SB Instrument Setup form and the SpectralSpec fields can be found in Section 8.4.3.

Below we first discuss the relatively simple Visual Spectral Editor for Science Goals. In Section 10.2, more
details about the Spectral Editor for SBs can be found.

10.1 The Visual Spectral Editor for Science Goals

In a Science Goal, the Visual Spectral Editor gives a very basic overview of the frequency setup and the associated
system parameters. The Visual Spectral Editor becomes visible via the Spectral tab in the Editors pane when
viewing the Spectral Setup section of a Science Goal (Phase 1 and Phase 2).

10.1.1 Overview of the Graphical Interface

The Visual Spectral Editor is divided into a number of panels:

• Visualisation: This is the heart of the Visual Editor, displaying the ALMA bands, atmospheric trans-
mission, spectral windows, sidebands and the first local oscillator as a function of frequency (in both the
observed and source frames).

• Spectral Type: Here you specify whether you wish to observe in spectral line or single continuum mode.
A spectral scan mode will one day also be possible. The number of polarization products is also specified.
The details of these fields are discussed in Section 6.3.3.

• The contents of this panel depending on what Spectral Type was chosen, but in each case is used for
entering the spectral line or continuum frequencies. The details of these fields are also discussed in Sec-
tion 6.3.3.
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• Spectral Setup Errors: If an impossible spectral setup has been defined, errors (in red) will appear here.

• Targets: This lists the sources that have been defined in the Field Setup secion of the Science Goal.
Selecting a particular source will cause the defined spectral lines to move based on the velocity of that
source. The positions of the sidebands will not move – they always correspond to the first source in the
list.

An example of the Visual Spectral Editor is given in Figure 10.1.

Figure 10.1: The graphical representation of the frequency information in a Science Goal. The top graph shows
the ALMA receiver bands, the transmission curve and the sidebands and LO1. The tables provide frequency
settings and source information.

10.1.2 Receiver and LO Visualisation

At the top of the Spectral Editor, the graph displays the frequency range within which ALMA can observe, the
available ALMA frequency bands, the atmospheric transmission curve, and the frequencies and bandwidths of
the spectral lines or continua. All frequency information is displayed both in the observed (sky) frame (top) and
in the rest-frame of the source (bottom). If some frequency information has been entered, the selected ALMA
band will turn blue whilst the remainder of the bands remain grey. This will also cause two vertical rectangles to
appear which represent the upper and lower sidebands of the receiver – these are located symmetrically around
the first local oscillator frequency (LO1).

Spectral windows which are defined by the user must be able to fit inside the sidebands, based on both their
positions and widths. If one or more spectral windows are defined which cannot be fit, the sidebands will be
displayed in a grey colour and red errors will appear in the Spectral Setup Errors panel. The frequencies of the
spectral windows will need to be redefined in order that a tuning solution can be found. This can be experimented
with by dragging the sidebands by grabbing LO1 with the mouse – if the sidebands are grey, the sidebands can
be moved and will stay where they are left. In conjunction with the Select Lines to Overlay... button it is
possible to see which lines it would be possible to observe with a single tuning.
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If spectral windows have been defined which do fit, then the sidebands will be displayed in yellow and will
move to reflect the tuning solution that was found automatically by the OT. The Spectral Setup Errors panel will
also be empty. The sidebands can still be dragged, but as soon as the mouse is released they will spring back to
their original position. This is to emphasise that moving the sidebands does not change the range of frequencies
that will be observed by ALMA. This is set purely by the entered spectral window information which must of
course be valid.

Below the graph there are tick boxes that enable the user to select whether the ALMA receiver bands, the
transmission curve and overlaid spectral lines should be displayed. The latter are chosen using the Select Lines
to Overlay... button which launches the Spectral Line Selection Tool (Section 5.6). The Viewport buttons
beneath the tickboxes can be used to fine tune the display.

Zoom and Pan in the Visualisations

When the mouse is placed in the spectral visualisation area, the cursor will change to a magnifying glass and two
sliding bars (with a default colour of dark green) appear above and below the display area. The latter indicate
the region that will be zoomed if the mouse is left-clicked and will follow the left and right movement of the
mouse. To zoom out you only need to right-click. The same functionality can be achieved if your mouse has a
scroll wheel.

If the display is zoomed, the spectral area beyond the boundaries of the viewing window (and therefore
invisible) may be brought into view through the use of the panning function. This is achieved by moving the
mouse into the green sliding bars. The cursor will turn into a hand symbol and the bars can be grabbed and the
display moved to the left and right.

10.2 The Visual Spectral Editor for Scheduling Blocks

The Visual Spectral Editor can also be used for specifying parameters of an Instrument Setup within a Scheduling
Block. The Visual Spectral Editor gives a graphical representation of the frequency information of the selected
receiver band, the rest-frame and observed frequencies, the atmospheric transmission curve, the basebands and
the spectral windows that are specified for each baseband.

The details of the complete Instrument Setup form can be found in Section 8.4.3). This section concentrates
on the setting up of basebands the spectral windows that lie within them.

10.2.1 Overview of the Graphical Interface

The Spectral Visual Editor can be invoked by selecting a Target with an attached Instrument Setup or by
selecting a specific Instrument Setup – click on the Spectral tab in the Editor pane in each case. On the left the
Visual Editor displays two graphs: the upper one shows the Receiver and LO visualisation and the lower one
the baseband visualisation. On the right is the corresponding form that would be shown if the Forms tab had
been chosen instead of the Spectral one. Parameters entered via the Visual Spectral Editor (either graphically
or using the form fields) become visible in the Forms editor and vice versa.

The Visual Spectral Editor shows if the SpectralSpec is used for one or more Targets. Be warned that when
an Instrument Setup is not attached to a Target, there is no redshift/velocity that can be used to calculate the
shift between the observed frequency and the frequency in the source frame.

10.2.2 Receivers and LO Visualisation

In the Spectral Editor at the top left, the graph displays the frequency range within which ALMA can observe,
the ALMA frequency bands (1-10), the atmospheric transmission curve, and the frequencies of the first local
oscillator and the upper and lower sidebands. The graph will also display the position of the basebands and their
bandwidth, once they are defined. The top scale of the graph gives the observing frequency scale, at the bottom
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Figure 10.2: The graphical representation of the frequency information about receivers and LO frequencies: the
frequency range for the selected receiver band (in this case Band 6), the frequency of the target (CO 2-1), the
LO1 frequency, the LSB and USB bands and the position of the basebands.

the frequency scale in the source (rest) frame is displayed. The shift of the two frequency scales with respect to
each other depends on the source velocity which includes the convention that was used to calculate the source
velocity: optical, radio or relativistic.

The checkboxes labelled Basebands, Other Transitions, BBC Centre Frequencies, Receiver Bands, Side
Bands and Transmission control whether or not the indicated information is shown on the graph. The button
Select Other Transitions can be used to display additional lines. The Zoom ... buttons can be used to fine-tune
the displayed information.

In the graph (see Fig. 10.2) the selected receiver band (field Receiver Band) is represented by the broader
hashed band with the blue colour. The narrower band represents the possible range of the LO1 frequency. The
LO1 frequency, the sidebands and the line to be observed and its identification have colours defined by the Option
→ Colours settings the menu.

The LO1 (and the USB and LSB) and the target frequency can be moved using the left button of the cursor.
When changing these frequency settings with the mouse the corresponding fields in the Frequency Setup panel
are updated. Moving the LO1 frequency and the sidebands positions allows the user e.g. to observe a particular
line together with the main target line.

10.2.3 Baseband and Spectral Windows Configuration

On the right the panel Spectral Spec contains the frequency fields for the observation: the rest frequency of
the line, the line identification and the receiver band. Other fields can also be defined but have no graphical
representation in the graph.

The Switching and Correlator Configuration panels have already been discussed in Chapter 8.4.3.

In a SpectralSpec up to four basebands can be specified using the Add Baseband button and within each
baseband up to 32 spectral windows can be defined. In the field of the panel BaseBand Configurations the
details of the baseband configuration(s) are displayed.

The top part of the this panel contains the information about the selected baseband configurations, followed
by the baseband details. Each of the basebands can be displayed by selecting the corresponding tab. The lower
part shows the information with the specifications of the spectral windows that are specified for this baseband
configuration. Each of the windows can be displayed by selecting its tab.

By specifying the baseband central frequency field Centre Frequency in BaseBand Configurations and given
the position of the LSB and USB (determined by the LO1 frequency in the Setup Preferences panel) the user
indirectly chooses whether the baseband will fall in the USB or the LSB. In the upper graphical display the
vertical line and the bars indicate the position of the LO1 frequency and the positions and the bandwidths of
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the chosen baseband configurations.

Initially, the position(s) of the selected baseband configuration(s) will not be optimal within the LSB and
USB. Also, as the LO2 frequency can only fall within certain ranges, the user defined LO1 setting (and hence
the LSB and USB) may have to be adjusted in order to achieve the requested central baseband frequency. Since
there is only one LO1 setting possible, in the case of multiple baseband specifications the LO1 and LO2 settings
have to be optimised to get closest to the requested centre baseband frequencies. The Spectral Editor provides
the functionality to do the optimisation.

In the panel LO Setup Preferences in the form on the right, the checkboxes for Sideband(s) to prioritise
allow you to select a sideband that is to be given priority in the LO optimisation. It is also possible to assign
priorities to basebands using numeric values between 0 and 100 in the Base band(s) config to prioritise
section. Pressing the Calculate LOs button will calculate the LO setup according to the chosen parameters.

The best setup (in terms of LO1 and LO2 settings) for a single or multiple baseband configuration is deter-
mined by calculating the error between the ideal and the adjusted LO2 setting for each of the basebands and
minimising the sum of these errors. After clicking on the Calculate LOs button, a summary of the optimisation
results can be seen in the Feedback pane, using the Information tab. Clicking on the expansion symbol >>
provides details, including the ideal setting of the LO1 and LO2 frequencies, the frequency offsets given the
system limitations in setting the LO2 frequencies and the adjusted LO1 and LO2 frequencies.

10.2.4 Baseband Visualisation

The second graph provides a more detailed visualisation of the basebands and the spectral windows for each for
the basebands. The functionality of the display is very similar to the Receiver and LO visualisation discussed
above. The hashed bar at the top below the scale represents the frequency band. Below the frequency band the
basebands are displayed. For each baseband its position, its bandwidth (nominal and effective) as well as the
baseband spectral windows are displayed.

When a baseband is selected in the BaseBand Configuration panel the display zooms in on the graphical
representation of the baseband. Tick boxes can be used to determine which additional information (Lines,
Receiver Bands, Transmission) is displayed and how the information is displayed. If checked, the Fold Basebands
and Fold Spectral Windows control allows the tool to draw basebands with non-overlapping ranges to be drawn
at the same y coordinate. This potentially allows more vertical space to be used for each element in the display,
which can improve clarity. An example of a baseband visualisation can be seen in Figure 10.3.

The buttons marked Zoom to Receiver Band and Zoom to Selected Baseband will zoom the display to
the respective range. Checking the Track selection control means that whenever a new baseband configuration
is selected in the tabbed pane to the right, the display will zoom to that baseband.
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Figure 10.3: Visualisation of the baseband configuration. Visible are part of the frequency band (hashed), the
transmission curve, four basebands and their spectral windows. For baseband 1 (BBC1 at 226 GHz) three
spectral windows are defined. The most optimal LO1 frequency is displayed after applying the Calculate LOs
button.
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Chapter 11

Project Management

When you start the OT, the Project Structure pane is empty since no observing project has been defined. After
having created (part of) a project, the OT can save your work in a local file which can be later restored. Projects
can of course also be submitted to the ALMA Archive. Details for opening, saving and project submission follow
below.

11.1 Open and Save a Project

11.1.1 Local Files

Exporting a project to a local project can be done at any point during the development of a project – there is
no requirement that the project should pass validation. Therefore, exporting to a local file is suitable for sharing
with collaborators: you may simply email this file around.

To export your project to a local disk file select File → Save. If the project is new, a dialog box will be
displayed in which you can select the directory and the name of a file to save to. If it had previously been
imported from your local file system (see below) then the original version will be overwritten. Selecting File →
Save As will display the dialog box and give you the option to create a new file on disk.

The project will be saved as an ALMA OT Project file with extension .aot, comprising XML files for each
entity within the project: the ObsProject, ObsProposal and any associated SBs. Be aware that the .aot file is
actually a .zip file, and therefore the standard unzip command must be used to give access to the XML files
of the saved project. Regarding manual changes to the XML, given the complicated structure of the saved code
this is STRONGLY discouraged and definitely NOT supported.

When exporting a project to an .aot file on disk, external documents like PDF files that you have attached
to your project will be exported too, and will be contained inside the resulting .aot file. This way, a co-worker
that you send the .aot file to will have all attached documents available when they import the .aot file.

You can also import an existing ALMA OT project file. In the menu bar, select File → Open Project → from
Disk.... You will get a file dialog with which you can locate the project input file and click on Open Project.
Before the retrieved project is loaded into the OT, the user will be asked if the current project in the OT can
be overwritten. The menu File → Open Project → Using Project Finder... gives a dialog that can be used to
find and select ALMA OT files in your local file system, based on a number of selection criteria.

11.1.2 ALMA Archive

A previously-submitted project can be retrieved and opened from the ALMA Archive via File → Open → From
ALMA Archive. Before the retrieved project is loaded into the OT, the user will be asked if the current project
in the OT can be overwritten. Retrieval of projects will follow certain ALMA policies. Clearly, the user can
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retrieve only his own projects. When selecting From ALMA Archive the Project Finder dialogue is launched. An
example of this is shown in Figure 11.1. Note that the search options all projects and all my projects are
only available to privileged users.

Figure 11.1: Example of the Project Finder dialogue window used to find projects in the ALMA Archive.

Similarly to finding local files, the Project Finder also allows browsing of the ALMA Archive and the loading
of projects for editing. As user authentication is now always used, the default choice is to search for all my
projects – only priveliged users will be able to search for all projects. You are free to choose any of the other
alternatives like searching for a certain project code. For all text searches, the additional options Exact Match
and Ignore Case may be specified. Hitting enter or clicking on Search will fill the search results table with the
corresponding projects found in the ALMA Archive. You can use the cursor keys to navigate the search results.
To open a project in the OT, press enter or double-click.

11.1.3 Project Conversion

When importing a project from disk it is scanned to see if it is a project created with the current version of the
OT. If it is not then the user is prompted to see if an attempt should be made to convert the project to the
current version. Answering Yes means that the OT will try to convert the project to the latest version before
loading it (see caveats below). If the upgrade is successful you will be to export the project as usual. The tool
does not export the original disk version.

Under some circumstances the conversion may not be entirely or at all successful. The following caveats and
remarks are useful to keep in mind when converting a older project to the current version of the OT:

1. It is recommended to run a validation after the conversion.

2. There are items which are new and for which it was felt that providing a default could be misleading. The
user will need to enter a value.

3. The conversion process can in principle work on all projects created since a little before User Test 4.0.
However, to avoid expending unnecessary effort, not every project version is supported, only those associ-
ated with major project data model changes. There are several interim versions that are not supported.
In general, it is expected that only those who use the tool on a frequent basis would be affected by this
limitation. If the limitation is found to cause a problem then the relevant migration can be implemented.

4. It is necessary to be connected to the internet when converting a project as parts of it rely on web access.

Please report any problems to the OT team, preferably including a copy of the project that is causing
problems.
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11.2 Project Validation

The OT offers two options for validating the Phase 1 and Phase 2 contents, thus ensuring that your project will
successfully submit to the ALMA Archive and be executable at the telescope.

11.2.1 Basic Validation

The first and most basic level of validation is run automatically as you build up your observing project. In filling
out the various forms, if any parameter for your observing project contains a non-permitted value, this value
will either turn red or a pop-up window will appear. The pop-up window provides the user with information
why the input is wrong and gives suggestions how to fix the problem. Examples are non-numerical input for the
source velocity, a negative frequency, a too large bandwidth or a target at a non-accessible declination.

11.2.2 The Validation Tool

A higher level of validation is offered by the Validator Tool. The main purpose of this validation is to check that
the input provided by the user is complete and consistent. Also, the validator ensures the compliance of the
project with a rather extensive set of rules that users need to follow so that observations can be scheduled. An
example of the first category is the check that the central observing frequency and the bandwidth falls within
the receiver band. An example of the second category is the check that the duration of the SB does not exceed
a certain limit imposed by the needs of flexible scheduling.

The Validation Tool can run anytime during the preparation of the project. Hence, when preparing a project
the user can immediately make sure that the parameter space is filled correctly and that the project complies
with the observatory’s procedures. Validation is performed by selecting File → Validate or by clicking on the
Validate icon in the OT Tool Bar. An example of the information the OT provides after running the Validator
Tool is shown in Figure 11.2.

Errors resulting from wrong or problematic parameter input should be fixed as they may affect proper
execution and will prevent your project from being submitted to the ALMA Archive. The errors are recorded in
a log that can be displayed via the Log tab in the Feedback pane of the OT. The log file runs in append mode
and hence all errors and warnings will be added at the end of the listing. Each of the messages in the log file
is provided with an indication of its severity. When clicking on the >> link preceding the message, the text is
expanded providing detailed information and advice how to correct. Warning messages are intended to call your
attention to rather unusual setups to confirm that they are really wanted.

The Problems tab in the Feedback pane provides a listing of the existing problems with the current input
parameters, where they occur and suggestions to how these problems can be resolved. The Problems tab will
display errors (red) as well as warnings (yellow). When errors or warnings occur the corresponding element(s)
in the project tree get marked visually as follows:

• An element that has provoked an error shows a little red overlay icon.

• An element that has provoked a warning shows a little yellow overlay icon.

• An element that contains a sub-element that has provoked an error or warning shows an italic caption text.

When double clicking on an entry in the Problems listing, the OT will automatically display the relevant
form of the observing project in the Editors pane. Hence, searching for the problem in your observing project
and correcting it is relatively simple. After reported problems have been corrected and after re-executing the
validation, the problem list will get shorter. To make sure that your project (Phase 1 proposal or Phase 2
program) will pass validation, the Problems tab should be empty or contain warnings only. Note that the width
of the columns can be adjusted by positioning the cursor at the boundaries of description cells at the top of the
columns.

Note that in the current version of the OT, the Log tab contains all output information the OT produces.
The future goal is to produce a separate validation report as a saveable/printable file. In addition to validation
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Figure 11.2: Display of the SB in the Project Structure pane, and the content of the Problems tab in the Feedback
pane after validating an (invalid) project. Note that the invalid SB components are marked in the project tree.

information on technical errors, future validation will also show error and warning messages related to scheduling
policies.

11.2.3 Validation During Submission

Validation is also automatically executed when a project (the Phase 1 proposal or Phase 2 program) is submitted
to the ALMA Archive. Under normal circumstances, validation errors will prevent an observing project from
being submitted and the project will not be executed. This will certainly apply for technical errors in the project
e.g. trying to observe outside existing frequency bands. However, this will also be the case if the user requests
technically feasible observations that are not foreseen by the observatory. To cover such cases, a system of waivers
may be introduced that could make a project pass validation, provided a waiver request to allow the exception
to that error condition had been submitted and approved beforehand.

Since this validation is performed at the time that the project reaches ALMA, the error report can take
several seconds before being received, or even minutes if a large project is submitted. This can become very
inconvenient if large projects are sent to the ALMA Archive. For this reason, you are strongly encouraged to
perform the validation of their projects before submitting them.
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11.3 Submit and Retrieve a Project

After a successful final validation and having saved the work locally, the proposal or program can be submitted
to the ALMA Archive. Please note that multiple submissions of a project are allowed! Submitted
projects can be retrieved from the archive, edited and then resubmitted, overwriting the previous submission.
Later, proposals that have been awarded observing time can be retrieved in order to produce the Phase-2
Scheduling Blocks. The project must then be submitted to the archive one last time so that the observations
can be performed using the SBs. The sections below describe how to submit to and retrieve from the ALMA
Archive.

11.3.1 Submit

Figure 11.3: Possible replies from the Archive upon a project submission: acceptance or rejection.

File → Submit Project will submit the current project and store it in the ALMA Archive, providing that
it passes validation. During submission, a connection between your local platform and the ALMA Archive is
initiated and subsequently dropped open the completion of the submission. During the actual submission of the
project to the ALMA Archive, a progress bar will be visible and additional submission attempts are not allowed.
Figure 11.3 shows the two possible returns from the Archive upon the submission of a project: Acceptance with
an unique project ID number or a window stating that the submission failed.

If the project has not been submitted before, a new project with a unique project code will be created. If
this is a resubmission of an existing project, it will be updated. Therefore, resubmission of your project will
overwrite the existing project in the ALMA Archive! For a genuine resubmission this does not cause any
problems. However, it is extremely important to realise that if a previously-submitted project is read back into
the OT and almost every detail of it changed, a subsequent submission will still overwrite the previous
submission!

To prevent this happening unintentionally, a warning will be displayed at submission time to make it clear
that you are about to overwrite an existing ALMA project. The top of the Project Structure pane will also
feature a prominent Submitted text field that should serve to remind you that this is a previously-submitted
proposal. If you do wish to submit a separate proposal to ALMA for the same deadline, then it must be created
from scratch with e.g. the New Proposal icon in the Toolbar, or by reading in a previously-submitted project as
a read-only template where its contents can be copied over to a separate, unsubmitted project.

The opposite problem also exists i.e. if you save a proposal just before submitting it and then subsequently
reload it into the OT, edit and resubmit, the lack of the various codes and identifiers that would have been
written in at submission time, will cause a completely new submission. We currently try to avoid this by,
after a proposal has been submitted, bringing up a dialogue that asks you to save the file to disk. The
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dialogue includes the Save button to launch a save dialogue. This problem can of course be avoided if edits for
resubmissions are only made to projects that have been retrieved from the ALMA Archive.

11.3.2 Retrieve

Project retrieval from the archive is straightforward. Either select File→ Open Project→ From ALMA Archive...
or click on the icon in the Toolbar.

11.3.3 Submit As New

Privileged users only can use File → Submit Project as New submit the current project to the ALMA Archive as
a new project. If the project has never been previously submitted then this is in fact the same as using Submit
(via File → Submit Project. However, if it has been submitted before then Submit Project as New will store a
new copy of the project to the Archive, completely separate from the original. Please note that for your own
tracking benefit it is probably a good idea to change the name of the project before using this feature. Obviously,
other changes may also be made to the project. Validation must be passed again of course.
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Appendix A

OT Installation and Configuration Issues

A.1 Installation and Run Details

When installing the OT and when running it, a number of messages may appear on the screen. Below follows a
summary of the known messages:

1. The installation of the OT using Java Web Start will include parts of the ALMA Common Software (ACS)
and the ALMA Archive that the OT depends on. The download of this software will be displayed by the
Java Web Start tool.

2. During installation a number of dialogue windows may appear - certainly the first or second time. However,
it is possible that an application may not appear to start (there is no little Close to exit window in the top
left) - this may be because a dialogue box is hidden somewhere waiting to be clicked: it is worth checking.
The proliferation of dialogue boxes does stop with repeated use of the software: it just immediately starts
on a click.

3. Security warnings: Depending on your browser security settings, you may see warning messages about
installing and running the software. If you are to test it please ignore them!

When you start the Observing Tool for the first time, in your home directory the installation procedure will
create the folder .almaot which contains the user’s preferences for running the Observing Tool.

A.2 OT Configuration

Using Java Web Start or the tarball installation procedure, the OT software has a default configuration suitable
for general users. The Observing Tool’s properties are read at the OT startup.

1. The OT comes with a set of factory settings or properties. These properties are contained in the binaries
of the application. Technically speaking, they are contained in the file called ObservingTool.properties
which is looked up in the application’s classpath – that is, in the .jar file distributed with the application
and not distributed separately.

2. The system then looks for an optional properties file (also called ObservingTool.properties) in the
startup directory; if the file is not found there, the system looks in the .almaot subdirectory of the user’s
home directory. If an optional properties file is found, its values override the factory settings. The OT
requires proper definition of these properties.

The current set of required properties is:

• ACS.managerhost
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• ACS.baseport

• alma.MicroArchive.DbDir

• otCDB.dir

• python.ot.libs

• otData.dir

A set of required properties must be defined in the configuration: if any one of them is not defined, the
application terminates. These properties are subject to change as the tool evolves. It is not expected that
you will need to change them, in particular not when using the OT in a User Test.

3. Finally, the system considers values given on the command line, like -Dparam=value, which override any
previously set values. This is only recommended for the Integration and Test Subsystem team ITS).

A.3 ACS Connection Configuration

Presently the list of possible ACS locations (see Section 4.3) is constructed from a set of "factory options", to
which is added the value obtained from $HOME/.almaot/ObservingTool.properties (set as ACS.managerhost)
if this file is present. This last value is used as the default, unless the file is not present in which case "acc" is
used as the default (for the ATF tests).

The initial value used by the OT may also be set by adding to the JAVA_OPTIONS environment variable
a value like -DACS.managerhost=your.acs.host.

In the current implementation it is not possible to change the persistent default from within the OT — this
may only be achieved by editing (or creating) the ObservingTools.properties file and changing the value.
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Appendix B

Troubleshooting

Information on troubleshooting problems you encounter with the OT are also maintained on the OT pages in
the ALMA Science Portal (http://www.almascience.org).

B.1 Glossary

There is a reasonable amount of confusion about Java, JRE, and other Java products and their version numbering.
Below you will find a small glossary that may be helpful for determining whether you have the correct software
and versions installed on your platform.

• JRE 6.0: The Java Runtime Environment. This you need. It contains the Java Virtual Machine (JVM
1.6, see below) and Java Web Start (JWS 1.6, see below).

• JVM 1.6: The Java Virtual Machine, gets started by the binary called java. Its version can be fond out
by the command java -version.

• JWS 1.6: Java Web Start, a mechanism to start java applications over the web and to download the most
recent version of these applications. JWS contains a so-called Java Application Cache Viewer (see below).

• Java Application Cache Viewer: The Cache Viewer is started by the binary called javaws and allows
the re-starting and uninstalling of local java applications. Initial download and first start of remote appli-
cations is done via the browser. Once downloaded an application gets displayed in the Java Application
Cache Viewer GUI.

B.2 General Installation Problems

1. I have an old version of Java and need to install Java 1.6.0
The early Java versions (prior to 1.6) are not compatible with the latest version of the OT. Therefore Java
version 1.6 needs to be installed. To do this please proceed as follows:

(a) Install the JRE 6.0 (you can easily have different versions of java on your system) Go to http://java.com/.
Download and install JRE Version 6.0 Update 5 or higher. Note that you can install JRE in your
directory tree.

B.3 Java Web Start Related Installation Problems

1. When using my browser to check the JWS installation, the Java Web Start Demo Application
does not appear on the screen.
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Normally when using Mozilla, Mozilla Firefox or Internet Explorer on Windows your browser should have
been setup for you already. However, when the demo does not appear your browser may need to be
(re-)configured to use Java Web Start.

For most browsers this is done by setting up the preferences. In the browser’s preferences menu this may be
called “File Associations” or “Helper Applications”, or something similar. The general idea is that files with
the extension .jnlp (Java Web Start application descriptors) should be handled by the Java Application
Cache Viewer, which is started by the binary javaws.

Assuming you are on Linux and have chosen the installation path
/usr/java/jre1.6.0_05/javaws/

• Mozilla:
Get the Downloads window
Open the Download folder. Double click on the ObservingTool.jnlp file or use the right mouse
button to open the file.

• Internet Explorer
In the Windows File Explorer (not the Internet Explorer), open Tools → Folder Options → File
Types Find “JNLP” (easiest by pressing the letter “J”) and go to “Advanced”. Select the “Launch”
action and press “Edit”. Into the text field “Application used ...” put this following line:
/usr/java/jre1.6.0_05/javaws/javaws.exe %1

The following browser configuration setting may be needed to indicate that .jnlp files should be invoked
using the helper application “javaws”.

MIME type
application/x-java-jnlp-file

Description
JNLP File (Java Web Start)

Extension
jnlp

Application
javaws

Note that if you have installed JRE 6.0 yourself in your own space then the binaries for it may not be in
your path. In this case you will need to specify the full path in the browser configuration in place of just
the name “javaws”. You will normally find it under the jre directory, for instance something like:

...somedirectory.../jre1.6.0_05/jre/javaws/javaws

or

...somedirectory.../jre1.6.0_05/javaws/javaws

Java Web Start may also ask about your “proxy”. This has to do with how you are connected to the
Internet. It is likely that you will simply be able to hit “OK” and carry on. If you encounter problems and
do not understand proxies then you may need to get your local IT support to help with this setting.

2. Disk space problems Java Web Start caches downloaded programs locally. For the ALMA Observing
Tool, this will require some 115 MB of space on your hard disk. In case you run out of disk space or exceed
your disk quota, you can change the location of the cache in the Java Control Panel in − > General − >
Temporary Internet Files − > Settings... − > Location field.

3. Other Web Start Problems Please go to the Java Web Start FAQ provided by Sun. The URL is
http://java.sun.com/javase/6/docs/technotes/guides/javaws/developersguide/faq.html
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4. OT is on screen but I’m permanently seeing dialog boxes saying "your current look-and-feel
caused an error" First try switching to a different Look-And-Feel in − > Options Appearance. If that
doesn’t help, you’re probably running a buggy version of Java. Please update your Java installation.

5. OT is on screen but I’m seeing "text" or "nothing" in the subwindows of the OT Your
configuration files have probably been corrupted by a non-graceful shutdown of the OT. Delete the folder
.almaot in your home directory, then retry.

6. The Observing Tool doesn’t come up If the startup fails, or the application freezes with the Splash-
screen showing, please try these – ascendingly dramatic – options:

(a) Delete the folder .almaot in your home directory, then retry.

(b) Delete the folder .almaot in your home directory. Open the Cache Viewer, select the Observing Tool
and press the Remove Selected Application button. By doing so, you have completely uninstalled
the OT from your machine. Now reinstall it as described above.

7. Problems with copy/paste SB (Mac only) If you have a Mac and are running the OT there may be
a problem with copy/paste of SB, when running the OT on a ssh -x (and not NoMachine).

The solution is to go into the X11 preferences, then tab ’Pasteboard’, then uncheck ’Update Pasteboard
when CLIPBOARD changes’, then restart X11.

B.4 Tarball Related Installation Problems

1. When I start the executable as described in Section 2.3, it seems that nothing happens.

Please have a look at the log file ot.log in the directory where you have installed the OT. A possible reason
could be that you don’t have Java installed properly. See above under “General Installation Problems”, or
talk to your Helpdesk.

B.5 Running Problems

1. The Startup of the OT fails, or freezes with showing the Splashscreen. If the startup of the OT
fails please try these ascendingly dramatic options:

(a) Delete the folder .almaot in your home directory, then retry.

(b) Delete .almaot, .acsjava and .jacorb_properties from your home directory. Retry.

(c) Reinstall the OT:

• If using Java Web Start, open the Cache Viewer with <path>/javaws and remove (= uninstall)
the OT. Note that you may have to include the path when starting up javaws.

• If you have a tarball installation, delete the installation folder

In any case, please provide us with an error report about your findings.

2. I’m permanently seeing dialog boxes “your current look-and-feel causes an error”

First try switching to a different Look-And-Feel in Options → Appearance. If that doesn’t help, you’re
probably running a buggy version of Java. Please update your Java installation.

3. I’m seeing “text” or “nothing” in the subwindows of the OT

Your configuration files have probably been corrupted by a non-graceful shutdown of the OT. Delete the
folder .almaot in your home directory, then retry.
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Appendix C

Create an External Ephemeris

This Appendix explains how to use the HORIZONS system provided by JPL to create a text file format ephemeris
file which can be used as an external ephemeris file in OT.

C.1 NASA resources for HORIZONS

• http://ssd.jpl.nasa.gov/horizons.cgi: Direct link to the HORIZONS web interface (which is what is covered
here)

• http://ssd.jpl.nasa.gov/?horizons: HORIZONS web page (web interface link can be found here, in addition
to multiple formats for documentation)

• ftp://ssd.jpl.nasa.gov/pub/ssd/Horizons_doc.pdf: PDF user manual. Provided as a reference (very de-
tailed, not required for following the steps outlined here)

C.2 Instructions and Setting

Below follow the instructions bullet list for making an output file from HORIZONS compatible with ALMA
software.

• Go to http://ssd.jpl.nasa.gov/horizons.cgi

• Ephemeris Type should be "Observer"

– This should be the default. If not, click the "change" link immediately to the right of "Ephemeris
Type", and select "Observer Table"

– Click "Use Selection Above" button

• Set your "Target Body"

– Click the "change" link immediately to the right to put in what you want

• "Observer Location" should be "Geocentric" (probably the default)

• "Time Span" should be set as needed (clicking "change" link immediately to the right to get fields for a
time range)

• "Table Settings":

– Click "change" link immediately to the right of "Table Settings"
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– This will bring up a lot of check boxes

– There are 2 checkboxes that must be checked:

∗ "Astrometric RA & DEC"
∗ "Obsrv range & rng rate"

– All other settings are optional

• Important: for "Display/Output"

– Click "change" link next to "Display/Output"

– Select "plain text"

– Click "Use Selection Above"

• Once done, double check your Current Settings, to make sure they match all the settings above.

• If OK, click the "Generate Ephemeris" button

• The page can then be saved as a file through the browser

– Remember to include the ".txt" extension on the filename
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Appendix D

Observatory Setups

In a Phase 2 program, apart for the defining Science Goals, Observatory Staff can also specify Observatory
Setups as part of the Science Plan. Currently, there are setups for holography and astro-holography, optical and
radiometric (also known as interferometric) pointing, baseline calibration and for calibration survey. The goals
can be added by right-clicking on the Science Plan node in the project tree and selecting one of the options in
the Add Observatory Setup from the context menu as appropriate. These options can also be found in the Edit
menu, under Add Observatory Setup.

D.1 Holography

D.1.1 Astro-Holography

To support setting up an Astronomical Holography SB a "helper" dialogue is provided. With the Science Plan
node highlighted either right click and select Add Astro-Holography Setup or from the Edit menu choose
Add Observatory Setup/Add Astro-Holography Setup. This will produce a dialogue asking for a source
name, an observing frequency and the name(s) of the reference antennas that is/are to be used:

• Source name: this will be resolved in the same way as would normally happen from the Field Source editor

• Observing Frequency (defaults to 104 GHz): This will be used to setup a spectral spec.

• Reference antennas: Provide a comma separated list of antennas, to be used in the ”Expert Parameters"
of the SB to direct which antenna(s) this SB should be executed on.

When clicking on OK an Astro-holography SB will be created. Naturally the SB may be edited afterwards in
the usual manner. In particular if one wish to enter a source that cannot be resolved by the usual name resolvers
then leave this field blank. The rest of the SB will be created and may be edited in the Field Source form then.
Similarly the reference antennas field may be left blank and filled (or changed) later.

This setup only allows for one target. More may be added to the SB later if desired.

D.2 Optical Pointing

Still to be added

97



D.3 Radiometric Pointing, Baseline Calibration, and Calibrator Sur-
vey

These three goals have a common structure. Each contains:

• A target list

• A calibrator list

• A spectral setup

Each source in the target list and calibrator list will be observed using the one spectral setup specified here.
The target list and calibrator list are edited using the target list and calibrator editors, described below, while
the spectral setup is edited using the same spectral setup editor as used throughout the OT. When the target
list, calibrator list and spectral setup are to your satisfaction, SBs can automatically generated from the goal
by right-clicking on the goal in the project tree and selecting Generate SBs from the selected goal, just as when
generating SBs from a Science Goal. The current SB generation strategy is to:

• Generate two observing groups: Observing Group 1, for initial calibrators, and Observing Group 2, for
goal targets and repeated calibrations.

• Create a virtual target for each calibrator in the calibrator list, apart from the phase calibrator. Each of
these calibration Targets is added to Observing Group 1, and will be observed in an initial calibration pass
when the project is executed.

• If a phase calibrator is specified, create a phase calibrator virtual Target and add it to Observing Group 2.
This phase calibration target will be observed at regular intervals throughout the project. The specifics of
how frequently it will be observed can be changed by editing the PhaseCalParameters, which can be found
as a leaf node of the generated SB in the project tree.

• A target will be created in Observing Group 2 for each calibrator in the predefined target list, or alterna-
tively one virtual target containing the user’s search criteria will be created if the list is to be generated at
project execution time.

Below the Target List and Survey Calibrators form are discussed. The form for the Spectral Setup is identical
to the form for a Science Goal (see Section 6.3.3.

D.3.1 Target List Editor

To edit the Target List expand the goal in the project tree and click on Target List. The Target List form is
displayed in Figure D.1.

The target list is compiled from the ALMA calibrator catalogue. These targets can either be explicitly set
beforehand, or the target list can be compiled by searching the ALMA calibrator catalogue at project execution
time.

To use a dynamically-generated target list, select the Generate target list at execution time option.
To edit the search criteria used to generate the target list, click the Edit Selection Criteria button to launch
the Target List Query Editor. This will start the Target List Query Editor where the search parameters can be
specified. The form is very similar to the Calibration Selection Tool described in Section 5.2 with the exception
of the maximum number of targets that can be specified here. An example form is visible in Figure D.2. A
search of the ALMA calibrator catalogue will be performed at project execution time and the resulting matches
used as the survey target list.

Alternatively, to fix the targets beforehand, select the User-selected target list option. This will startup
the Target List Selector which is identical to the Calibration Selection Tool. After the selection the various
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Figure D.1: An example of the Observatory Goal Survey Target form.

buttons at the bottom can be used to manupulate the ]User-selected target list. e.g Add... and Remove to add
and remove calibrators.

The integration time spent on each target in the target list can be set by entering a value in the Integration
time per target entry box.

D.3.2 Calibration Editor

Expand the goal in the project tree and click on Survey Calibrators to edit the calibrators observed as part
of your project. The calibrators editor is shown in Figure D.3.

Note that calibrators are always found by searching the ALMA calibrator catalogue at project execution
time!

There are two options here: either select the System selects calibration strategy option and let the
OT decide on which calibrators should be observed and the search criteria used to find them by, or explicitly set
the calibrators yourself.

If you wish to set the calibrators yourself, select the User-defined calibration option and use the Add
Calibration... button to add calibrators to your goal. Eight different kinds of calibrator target can be
added: amplitude, atmospheric, bandpass, delay, focus, phase, pointing and polarization. The search criteria
used to identify each type of calibrator can be edited by clicking the appropriate Edit Calibrator Selection
Criteria... button in the table, next to the calibrator type. This start the Calibration Query Editor in which
the calibrators can be selected. Calibrators can be removed from the list by clicking the Delete Selected
Calibration button.

99



Figure D.2: An example of the Target List Query form. The maximum number of targets is unlimited.

Figure D.3: An example of the Survey Calibrators form.
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Appendix E

Expert Parameters

Expert Parameters will not be exposed to the normal user by the time of the first Call for Proposals. Documen-
tation about these will normally be placed in this Appendix.

E.1 Advanced Parameters in Observing Parameters and Scheduling
Blocks

In the Observing Parameters panel of a project, an additional panel Advanced Parameters enables the devel-
opment of observing modes and can be used for Keyword-Value pairs specification. They are not intended for
operational usage but rather to decouple script development from the release cycle of the Alma Project Data
Model (APDM) and the Observing Tool.

Similarly, the same concept has been added to Scheduling Blocks. This is also for expert use only and is
intended to allow ALMA commissioning scientists to experiment to see what is needed in the way of passing
parameters to the standard observing mode scripts. The expectation is that as certain keywords are found
necessary then they will be considered for permanent addition to the APDM.

Figure E.1: The Advanced Parameters panel in Observing Parameters and Scheduling Blocks forms for specifying
expert parameters via Keyword-Value pairs.

The editor for expert parameters is the same in both places: A panel called Advanced Parameters is available
in the SB or Observing Parameters, collapsed by default. Opening it reveals a table editor that allows the addition
and deletion of free-form Keyword-Value pairs. These are simply strings passed to the SB and interpreted by
the script in any way the script writer desires.
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Appendix F

Acronym List

2SB: Two sideband (ALMA bands 3–8)
ACA: Atacama Compact Array
ALMA: Atacama Large Millimeter/submillimeter Array
APC: Atmospheric Phase Correction
ARC: ALMA Regional Centre
ASC: ALMA Sensitivity Calculator
ATF: Alma Test Facility
BBC: BaseBand Configuration
BL: Baseline (e.g. BL Correlator)
DBB: Database Browser
DFS Data Flow System
DSB: Double Sideband (ALMA bands 9 and 10)
FOV: Field Of View
FFT: Fast Fourier Transform
HLA: High Level Analysis
GUI: Graphical User Interface
ID: Identifier
IPT: Integrated Product Team
JDK: Java Development Kit
JRE: Java Runtime Environment
JVM: Java Virtual Machine
LO: Local Oscillator
LSB: Lower Side Band
ObsUnitSet: Observation Units Set
OT: Observing Tool
OTF: On The Fly (mapping)
ObsUnitSet: Observating Units Set
PI: Principal Investigator
SB: Scheduling Block
SSB: Single Sideband (ALMA bands 1 and 2)
SSR: Science Software Requirements
SFI: Single Field Interferometry
TAC: Time Allocation Committee
TFB: Tunable Filter Bank
VLA: Very Large Array
USB: Upper Side Band
UT: User Test
XML: Extensible Markup Language
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12m Array, 28
7m Array, 28

About Basebands, SideBands and Spectral Win-
dows, 59

About the OT, 16
Access the Template Library, 25
Acknowledgments, 8
Acronym List, 103
ACS Connection Configuration, 90
Add a Calibration Target, 56
Add a Science Target, 55
Adding calibrators, 26
Algorithm Used for Splitting SBs, 47
ALMA Regional Centers, 8
ALMA Archive, 45
ALMA Archive, 83
ALMA Common Software, 90
ALMA Data Flow System, 13
ALMA Project Data Model, 101
ALMA Proposal Review Committee, 15
ALMA Template Library, 25
ALMA user database, 8, 35
Astro-Holography, 97
Attaching New or Existing Resources, 66
Attaching Resources to Targets, 66

Baseband and Spectral Windows Configuration,
80

Baseband Configuration, 62
Baseband Specifications, 63
Baseband Visualisation, 81
Basebands

spectral windows, 63
Baseline calibration, 98
Basic concepts, 13
Basic Information, 45
Basic Validation, 85
Brightness temperature, 28

Calibration, 98
Calibration Selection Tool, 27
Calibration Setup, 40
Calibration target, 56
Calibrator Selection Tool, 26
Configuration, 20, 89

baseband, 62

correlator, 61
spectral windows, 80

Contextual help, 20
Continuum observations, 40
Control and Performance, 41
Conversion of a project, 84
Copy a Template Science Goal to your Proprosal,

25
Correlator Configuration, 61
Create a Phase 2 Observing Programme Struc-

ture, 49
Create a Phase 1 Proposal, 33
Create a Project, 49
Create Science Goals, 46
Creating an External Ephemeris, 95
Credits and Acknowledgments, 8

Default target type, 37
Disk space, 92
Disk Space Required, 9
Drag and drop, 17

Edit options, 17
Editors Pane and the Editor Types, 20
Enabled privileged operations, 23
Ephemeris, 38, 95
Exiting the OT, 24
Expert Parameters, 101

Features, 17
Feedback Pane, 20
Field Patterns

point, 73
rectangle, 74

Field Patterns for Scheduling Blocks, 73
Field Setup, 37
Field Source, 26
Field Sources, 54
Field Sources, 58
Filling the Phase 1 with Science Goals, 36
Flux density, 28
Frequency switching, 61

General Installation Problems, 91
Generate Scheduling Blocks, 46
Glossary, 91
GUI Parameter Fields, 16
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Hardware and Software Prerequisites, 9
Help, 12
Help, 16
High level analysis, 8
Holography, 8
Holography, 97
HORIZONS, 95

Images, loading, 71
Install and Run, 9
Installation

tarball, 11
Installation, 11
Installation and Run Details, 89
Instructions and Setting, 95
Instrument Setup, 54

choices, 60
spectral specs, 60

Instrument Setup, 60
Introduction, 7
Investigator Search GUI, 35

Java, 7, 91
Java Application Cache Viewer, 11
Java Runtime Environment, 10
Java Software, 10
Java Virtual Machine, 10
Java Web Start, 9

offline usage, 11
start OT with, 10
Verifying, 10

Java Web Start, 10
Java Web Start Related Installation Problems,

91
Jave Web Start

Installation, 91
JPL Horizons format, 38

LO Configuration Tool, 26
LO visualisation, 79
Loading External Images, 71
Loading Project Information, 45
Local Files, 83
Log file, 12
Lower sideband, 59

Main Graphical Interface, 16
Manuals, 16
Menu

Debug, 17
Edit, 17
File, 17
Help, 17
Search, 17
Tool, 17
View, 17

Menu and Tool Bar, 17
Multiple queries, 35
Multiple transitions, 30
Multiple Single Point Fields, 72

NASA resources for HORIZONS, 95

Observatory Setups, 97
Observatory setups, 97
Observing Programme, 15
Observing Group, 56
Observing Groups, 56
Observing Parameters, 26, 54
Observing Parameters, 64
Observing Programme, 7, 13, 45

create of science goals, 46
loading information, 45
schedule block creation, 46
scheduling block, 51
scheduling blocks, 49
science goal information, 45
science goals, 45
structure, 49
targets, 53
validation and submission of science goals, 48

Observing Proposal, 7, 13, 15, 33
calibration, 40
control and performance, 41
create, 33
field setup, 37
information form, 34
science goals, 36
science goals general, 37
single continuum, 40
spectral setup, 39
submission, 43
summary information, 43
validation, 43

Observing Tool, 7
overview, 15

Observing Unit Set, 14, 50
Offline mode, 11
Online mode, 11
Optical pointing, 8
Optical Pointing, 97
OT

software team, 8
Configuration, 89
Installation, 89
installation problems, 91
Menu bar, 16

OT Configuration, 20, 89
OT Installation and Configuration Issues, 89
OT Main Graphical Interface, 16
OT Panes, 18
Other Field Patterns, 75
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Overview of the Graphical Interface, 69, 77, 79
Overview of the Observing Tool, 15
Overview pane, 20

Panes, 18
editor, 20
feedback, 20
overview, 20
project structure, 19

Parameters fields, 16
Phase 1, 15
Phase 2, 13
Phase 1, 13
Phase 2, 15, 45
Phase 2 Scheduling Blocks, 49
Phase 2 Science Goals, 45
Phase 1 Observing Proposal, 33
Phase 1 Observing Proposals, 13
Phase 2 Observing Programme, 13
Point, 73
Polarision, 39
Preferences, 16, 21

Advanced, 23
Appearance, 21
Connection, 23
Dialog, 22
Telescope, 23

Prerequisites, 9
Principle investigator, 35
Project

create a, 49
open, 83
save, 83
submission and retrieval of a, 87

Project Conversion, 84
Project Finder, 45
Project Management, 83
Project Structure Pane, 19
Project submission, 67
Project Validation, 23, 85
Projects

conversion, 84
Proposal Information Form, 34
Proposal information form, 34
Purpose, 7
PWV, 28

Question mark, 16
Quickstart Guide, 8

Radiometric pointing, 98
Radiometric Pointing, Baseline Calibration, and

Calibrator Survey, 98
Receiver and LO Visualisation, 78
Receiver and LO visualisation, 78
Receivers and LO Visualisation, 79

Receivers visualisation, 79
Rectangle, 74
Rectangular Field, 73
Reference Manual, 16
Reference Manual and Quickstart Guide, 8
Release Information, 8
Representative frequency, 42
Resources

field source, 58
observing parameters, 64

Resources, 57
Resources, attaching of, 66
Resources: Field Sources, 54
Resources: Instrument Setup, 54
Resources: Observing Parameters, 54
Retrieve

project, 87
Retrieve, 88
Running problems, 93
Running the OT offline, 11

Save and Open Project as Template, 25
Scheduling Block, 7

targets and resources, 52
Scheduling Block, 51
Scheduling Block Information, 70
Scheduling Block Restrictions, 47
Scheduling Blocks, 49

adding target, 55
field patterns, 73
instrument setup, 60
resources, 57
restrictions, 47
splitting of, 47
targets, 54
visual spatial editor, 70
visual spectral editor, 79

Scheduling Blocks, 14
Science requirements, 23
Science Goal Information, 70
Science Goal Visual Editors, 46
Science Goals, 33

general, 37
phase 2, 46
phase I, 36
target types, 72
validation, submission, 48
visual editors, 46
visual spatial editor, 70
visual spectral editor, 77

Science Goals, 14
Science Goals - General, 37
Science requirements, 8
Search criteria, 26
Sensitivity Calculator, 27
Sensivity, 28
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Sideband, 27
Sideband Filter, 30
Sidebands, 59
Single Continuum, 40
Single point field, 37
Single rectangular field, 37
Solar objects, 38
Source list, 38
Source velocity, 37
Spectral line transitions, 29
Spectral line catalogue, 29
Spectral Line Selection Tool, 29
Spectral Setup, 39
Spectral setup, 39
Spectral specifications, 60
Spectral windows, 80

up to 4, 39
Spectral Windows, 59
Spectral windows, 63
Spectral windows configuration, 80
Splitting of Scheduling Blocks, 47
Square Law Setup, 61
Starting the OT, 10, 12
Starting Up, 49
Submit

as new, 88
observing programme, 67
project, 87
proposal, 43

Submit, 87
Submit and Retrieve a Project, 87
Submit As New, 88
Submit the Project, 67
Summary Information, Validation and Submis-

sion, 43
Supported Platforms, 9

Tarball
installation, 93
start OT with, 12

Tarball Installation, 11
Tarball Related Installation Problems, 93
Target folder, 26
Target List Editor, 98
Target types

multiple single point fields, 72
rectangular field, 73
science goals, 72

Target Types for Science Goals, 72
Targets

calibration, 56
Targets, 53, 54
Targets and Resources, 52
Targets, added a, 55
Telescope Pointing Patterns, 72
Template Library

copy a science goal, 25
The Validation Tool, 85
The Visual Spatial Editor, 69
Three choices for the Instrument Setup, 60
Tool bar, 16

Add Observing Unit Set, 18
Add Schedule Block, 18
ALMA Calibrator Tool, 18
Generate SBs for the Selected Goal, 18
Go to next Problem, 18
Go to previous Problem, 18
Help, 18
New Phase 1 Science Goal, 18
New Phase 2 Science Goal, 18
New Proposal (Phase 1), 18
New Proposal (Phase 2), 18
Open Project from ALMA Archive, 18
Open Project from Disk, 18
Save Project to Disk, 18
Sensitivity Calculator, 18
Show the ALMA Template Archive, 18
Validate, 18

Tool Bar and Zoom Functions, 71
ToolsTools, 25
Tooltip, 16
Tooltips, 16
Total Power Array, 28
Troubleshooting, 91

Units, 16
Up to 4 spectral windows, 39
Upper and Lower Sideband and Basebands, 59
Upper sideband, 59
User Support, 8
Using an Ephemeris, 38

Validation
basic, 85

validation, 23
Validation During Submission, 86
Verifying Java Web Start, 10
Visual Spatial Editor

Gui overview, 69
loading external images, 71
scheduling block information, 70
science goals, 70
telescope pointing patterns, 72
toolbar and zoom functions, 71

Visual Spatial Editor Useful Features, 75
Visual Spectral Editor

Gui overview for scheduling blocks, 79
Gui overview for science goals, 77

Visual Spectral Editor, 77
Visual Spectral Editor for Scheduling Blocks, 79
Visual Spectral Editor for Science Goals, 77
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Water vapour, 28

Zoom and pan, 79
Zoom and Pan in the Visualisations, 79
Zoom functions, 71
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